aboutsummaryrefslogtreecommitdiffstats
path: root/util/dvbnet/Makefile
diff options
context:
space:
mode:
authorMark Purcell <msp@debian.org>2008-06-22 11:00:40 +1000
committeretobi <git@e-tobi.net>2013-09-03 09:48:42 +0200
commit891c51ff368ed700dec6025eeb47ce4d96f76418 (patch)
tree3729664829e4faa691d403274f38eb10890b533c /util/dvbnet/Makefile
parent1c6e1f28f54ec2606c23936c1d8689f2be55a86c (diff)
parentab959d7b4194715870128e616b8e29d4a101e488 (diff)
downloadlinux-dvb-apps-891c51ff368ed700dec6025eeb47ce4d96f76418.tar.gz
Imported Debian patch 1.1.1+rev1207-1debian/1.1.1+rev1207-1
Diffstat (limited to 'util/dvbnet/Makefile')
-rw-r--r--util/dvbnet/Makefile32
1 files changed, 9 insertions, 23 deletions
diff --git a/util/dvbnet/Makefile b/util/dvbnet/Makefile
index 187dee2..c9ebab9 100644
--- a/util/dvbnet/Makefile
+++ b/util/dvbnet/Makefile
@@ -1,29 +1,15 @@
+# Makefile for linuxtv.org dvb-apps/util/dvbnet
-CC = gcc
-CFLAGS = -g -O2 -MD -Wall -I. -I../../include
-LFLAGS =
+binaries = dvbnet
-OBJS = dvbnet.o
-TARGET = dvbnet
-DESTDIR = /usr/local/bin/
+inst_bin = $(binaries)
-all: version.h $(TARGET)
+CPPFLAGS += -I../../lib
+LDFLAGS += -L../../lib/libdvbapi
+LDLIBS += -ldvbapi
-.c.o:
- $(CC) $(CFLAGS) -c $< -o $@
+.PHONY: all
-$(TARGET): $(OBJS)
- $(CC) -o $@ $(OBJS) $(LFLAGS)
-
-version.h:
- printf '#define VERSION_INFO "%s (Build %s)"\n' \
- "`cat $@.in`" "`date +'%a %b %d %X %Y'`" > $@
-
-install: all
- install -m 755 $(TARGET) $(DESTDIR)
-
-clean:
- rm -f $(TARGET) $(OBJS) version.h core* *~ *.d
-
--include $(wildcard *.d) dummy
+all: $(binaries)
+include ../../Make.rules