aboutsummaryrefslogtreecommitdiffstats
path: root/util/dvbdate/Makefile
diff options
context:
space:
mode:
authorMark Purcell <msp@debian.org>2008-06-22 11:00:40 +1000
committeretobi <git@e-tobi.net>2013-09-03 09:48:42 +0200
commit891c51ff368ed700dec6025eeb47ce4d96f76418 (patch)
tree3729664829e4faa691d403274f38eb10890b533c /util/dvbdate/Makefile
parent1c6e1f28f54ec2606c23936c1d8689f2be55a86c (diff)
parentab959d7b4194715870128e616b8e29d4a101e488 (diff)
downloadlinux-dvb-apps-891c51ff368ed700dec6025eeb47ce4d96f76418.tar.gz
Imported Debian patch 1.1.1+rev1207-1debian/1.1.1+rev1207-1
Diffstat (limited to 'util/dvbdate/Makefile')
-rw-r--r--util/dvbdate/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/util/dvbdate/Makefile b/util/dvbdate/Makefile
index ea514db..2602512 100644
--- a/util/dvbdate/Makefile
+++ b/util/dvbdate/Makefile
@@ -1,25 +1,15 @@
+# Makefile for linuxtv.org dvb-apps/util/dvbdate
-CC = gcc
-CFLAGS = -g -O2 -MD -Wall -I. -I../../include
-LFLAGS =
+binaries = dvbdate
-OBJS = dvbdate.o
-TARGET = dvbdate
-DESTDIR = /usr/local/bin/
+inst_bin = $(binaries)
-all: $(TARGET)
+CPPFLAGS += -I../../lib
+LDFLAGS += -L../../lib/libdvbapi -L../../lib/libucsi
+LDLIBS += -ldvbapi -lucsi
-.c.o:
- $(CC) $(CFLAGS) -c $< -o $@
+.PHONY: all
-$(TARGET): $(OBJS)
- $(CC) -o $@ $(OBJS) $(LFLAGS)
-
-install: all
- install -m 755 $(TARGET) $(DESTDIR)
-
-clean:
- rm -f $(TARGET) $(OBJS) core* *~ *.d
-
--include $(wildcard *.d) dummy
+all: $(binaries)
+include ../../Make.rules