aboutsummaryrefslogtreecommitdiffstats
path: root/util/dvbdate/Makefile
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:38 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:38 +0200
commit6e40287e2f39a80fc72bd8d0fbc1a8334d688c2d (patch)
tree024bef311226653bdd1da4fa588becf5098bcff7 /util/dvbdate/Makefile
downloadlinux-dvb-apps-6e40287e2f39a80fc72bd8d0fbc1a8334d688c2d.tar.gz
Imported Upstream version 1.1.0upstream/1.1.0
Diffstat (limited to 'util/dvbdate/Makefile')
-rw-r--r--util/dvbdate/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/util/dvbdate/Makefile b/util/dvbdate/Makefile
new file mode 100644
index 0000000..ea514db
--- /dev/null
+++ b/util/dvbdate/Makefile
@@ -0,0 +1,25 @@
+
+CC = gcc
+CFLAGS = -g -O2 -MD -Wall -I. -I../../include
+LFLAGS =
+
+OBJS = dvbdate.o
+TARGET = dvbdate
+DESTDIR = /usr/local/bin/
+
+all: $(TARGET)
+
+.c.o:
+ $(CC) $(CFLAGS) -c $< -o $@
+
+$(TARGET): $(OBJS)
+ $(CC) -o $@ $(OBJS) $(LFLAGS)
+
+install: all
+ install -m 755 $(TARGET) $(DESTDIR)
+
+clean:
+ rm -f $(TARGET) $(OBJS) core* *~ *.d
+
+-include $(wildcard *.d) dummy
+