aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
authorMark Purcell <msp@debian.org>2008-06-22 11:00:40 +1000
committeretobi <git@e-tobi.net>2013-09-03 09:48:42 +0200
commit891c51ff368ed700dec6025eeb47ce4d96f76418 (patch)
tree3729664829e4faa691d403274f38eb10890b533c /test/Makefile
parent1c6e1f28f54ec2606c23936c1d8689f2be55a86c (diff)
parentab959d7b4194715870128e616b8e29d4a101e488 (diff)
downloadlinux-dvb-apps-891c51ff368ed700dec6025eeb47ce4d96f76418.tar.gz
Imported Debian patch 1.1.1+rev1207-1debian/1.1.1+rev1207-1
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile64
1 files changed, 34 insertions, 30 deletions
diff --git a/test/Makefile b/test/Makefile
index ddff9ab..30cb9e3 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,37 +1,41 @@
-# Makefile for Linux DVB API Version 3 test programs
+# Makefile for linuxtv.org dvb-apps/test
-CC = gcc
-CFLAGS = -g -O2 -W -Wall -I../include
+objects = hex_dump.o lnb.o
-TARGETS = \
- diseqc \
- set22k \
- sendburst \
- setvoltage \
- setpid \
- video \
- test_sections \
- test_sec_ne \
- test_pes \
- test_dvr \
- test_dvr_play \
- test_tt \
- test_av \
- test_av_play \
- test_vevent \
- test_stc \
- test_stillimage
+binaries = diseqc \
+ sendburst \
+ set22k \
+ setpid \
+ setvoltage \
+ test_av \
+ test_av_play \
+ test_dvr \
+ test_dvr_play \
+ test_pes \
+ test_sec_ne \
+ test_sections \
+ test_stc \
+ test_stillimage \
+ test_tt \
+ test_vevent \
+ evtest \
+ video \
+ szap2
-# test \
-# test_audio \
-# test_front \
-# test_switch \
-# test_video \
+.PHONY: all
-all: $(TARGETS)
+all: $(binaries)
+ make -C libdvbcfg $@
+ make -C libdvben50221 $@
+ make -C libesg $@
+ make -C libucsi $@
-test_sections test_sec_ne test_pes test_tt: hex_dump.o
+$(binaries): $(objects)
-clean:
- rm -f $(TARGETS) *.o
+clean::
+ make -C libdvbcfg $@
+ make -C libdvben50221 $@
+ make -C libesg $@
+ make -C libucsi $@
+include ../Make.rules