summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:38 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:38 +0200
commit6e40287e2f39a80fc72bd8d0fbc1a8334d688c2d (patch)
tree024bef311226653bdd1da4fa588becf5098bcff7 /test/Makefile
downloadlinux-dvb-apps-6e40287e2f39a80fc72bd8d0fbc1a8334d688c2d.tar.gz
Imported Upstream version 1.1.0upstream/1.1.0
Diffstat (limited to '')
-rw-r--r--test/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
new file mode 100644
index 0000000..ddff9ab
--- /dev/null
+++ b/test/Makefile
@@ -0,0 +1,37 @@
+# Makefile for Linux DVB API Version 3 test programs
+
+CC = gcc
+CFLAGS = -g -O2 -W -Wall -I../include
+
+TARGETS = \
+ diseqc \
+ set22k \
+ sendburst \
+ setvoltage \
+ setpid \
+ video \
+ test_sections \
+ test_sec_ne \
+ test_pes \
+ test_dvr \
+ test_dvr_play \
+ test_tt \
+ test_av \
+ test_av_play \
+ test_vevent \
+ test_stc \
+ test_stillimage
+
+# test \
+# test_audio \
+# test_front \
+# test_switch \
+# test_video \
+
+all: $(TARGETS)
+
+test_sections test_sec_ne test_pes test_tt: hex_dump.o
+
+clean:
+ rm -f $(TARGETS) *.o
+
version 0+git20140611.14bd6c7upstream/0+git20140611.14bd6c7Jonathan McCrohan7-11/+60 2014-05-13New Upstream Snapshot (commit 1246b27)Jonathan McCrohan1-0/+6 2014-05-13Imported Upstream version 0+git20140512.1246b27upstream/0+git20140512.1246b27Jonathan McCrohan391-301/+3983 2014-04-05Release 0+git20140326.cfc2975-1debian/0+git20140326.cfc2975-1Jonathan McCrohan1-2/+2 2014-04-05d/control: update Homepage (upstream has moved from Gitweb to cgit)Jonathan McCrohan2-1/+2 2014-04-05New Upstream Snapshot (commit cfc2975)Jonathan McCrohan1-0/+6 2014-04-05Imported Upstream version 0+git20140326.cfc2975upstream/0+git20140326.cfc2975Jonathan McCrohan118-656/+877 2014-01-16Release 0+git20140107.1850cf8-1debian/0+git20140107.1850cf8-1Jonathan McCrohan1-2/+2 2014-01-16Update Standards Version to 3.9.5Jonathan McCrohan2-1/+9