aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libucsi/Makefile
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
commitab959d7b4194715870128e616b8e29d4a101e488 (patch)
tree61a746231d30817be73416a7d67763fd677a1042 /lib/libucsi/Makefile
parent6b350466c4902c5b137e0efaf1d189128a7f18f5 (diff)
downloadlinux-dvb-apps-ab959d7b4194715870128e616b8e29d4a101e488.tar.gz
Imported Upstream version 1.1.1+rev1207upstream/1.1.1+rev1207
Diffstat (limited to 'lib/libucsi/Makefile')
-rw-r--r--lib/libucsi/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/lib/libucsi/Makefile b/lib/libucsi/Makefile
new file mode 100644
index 0000000..19ab268
--- /dev/null
+++ b/lib/libucsi/Makefile
@@ -0,0 +1,34 @@
+# Makefile for linuxtv.org dvb-apps/lib/libucsi
+
+includes = crc32.h \
+ descriptor.h \
+ endianops.h \
+ section.h \
+ section_buf.h \
+ transport_packet.h \
+ types.h
+
+objects = crc32.o \
+ section_buf.o \
+ transport_packet.o
+
+lib_name = libucsi
+
+CPPFLAGS += -I../../lib
+
+.PHONY: all
+
+all: library
+
+include atsc/Makefile
+include dvb/Makefile
+include mpeg/Makefile
+
+.PHONY: $(sub-install)
+
+install:: $(sub-install)
+
+$(sub-install):
+ $(MAKE) -C $@ install
+
+include ../../Make.rules