aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libesg/bootstrap/Makefile
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
commitab959d7b4194715870128e616b8e29d4a101e488 (patch)
tree61a746231d30817be73416a7d67763fd677a1042 /lib/libesg/bootstrap/Makefile
parent6b350466c4902c5b137e0efaf1d189128a7f18f5 (diff)
downloadlinux-dvb-apps-ab959d7b4194715870128e616b8e29d4a101e488.tar.gz
Imported Upstream version 1.1.1+rev1207upstream/1.1.1+rev1207
Diffstat (limited to 'lib/libesg/bootstrap/Makefile')
-rw-r--r--lib/libesg/bootstrap/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/libesg/bootstrap/Makefile b/lib/libesg/bootstrap/Makefile
new file mode 100644
index 0000000..16a2457
--- /dev/null
+++ b/lib/libesg/bootstrap/Makefile
@@ -0,0 +1,24 @@
+# Makefile for linuxtv.org dvb-apps/lib/libesg/bootstrap
+
+.PHONY: sub-error-bootstrap
+
+sub-error-bootstrap:
+ $(error You can't use this makefile directly.)
+
+ifneq ($(lib_name),)
+
+objects += bootstrap/access_descriptor.o \
+ bootstrap/provider_discovery_descriptor.o
+
+sub-install += bootstrap
+
+else
+
+includes = access_descriptor.h \
+ provider_discovery_descriptor.h
+
+include ../../../Make.rules
+
+lib_name = libesg/bootstrap
+
+endif
Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
linuxtv-dvb-apps-1.?
======================

Linux DVB API applications and utilities.

All applications support the DVB-S, DVB-C, DVB-T, and ATSC standards.

Main User Applications:
util/scan	- Scan for channels on your digital TV device.
util/gnutv	- Tune, watch and stream your TV.

General Utilities:
util/dvbdate	- Set your clock from digital TV.
util/dvbnet	- Control digital data network interfaces.
util/dvbtraffic	- Monitor traffic on a digital device.
util/femon	- Monitor the tuning on a digital TV device.
util/zap	- *Just* tunes a digital device - really intended for developers.

Hardware Specific Utilities:
util/av7110_loadkeys	- Load remote keys into an av7110 based card
util/dib3000-watch	- Monitor DIB3000 demodulators
util/dst-utils		- Utilities for DST based cards.
util/ttusb_dec_reset	- Reset a TechnoTrends TTUSB DEC device.

Libraries:
lib/libdvbapi	- Interface library to digital TV devices.
lib/libdvbcfg	- Library to parse/create digital TV channel configuration files.
lib/libdvbsec	- Library for Satellite Equipment Control operations.
lib/libucsi	- Fast MPEG2 Transport Stream SI table parsing library.
lib/libdvben50221- Complete implementation of a Cenelec EN 50221 CAM stack.
lib/libdvbmisc	- Miscellaneous utilities used by the other libraries.

Various testing applications also live in test.

For convenience, dvb-apps contains a copy of the DVB API include
files as they are contained in the linuxtv-dvb-1.? release
and the 2.6.x Linux kernel.

Johannes Stezenbach <js@convergence.de>
Andrew de Quincey <adq_dvb@lidskialf.net>