aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libesg/Makefile
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
commitab959d7b4194715870128e616b8e29d4a101e488 (patch)
tree61a746231d30817be73416a7d67763fd677a1042 /lib/libesg/Makefile
parent6b350466c4902c5b137e0efaf1d189128a7f18f5 (diff)
downloadlinux-dvb-apps-ab959d7b4194715870128e616b8e29d4a101e488.tar.gz
Imported Upstream version 1.1.1+rev1207upstream/1.1.1+rev1207
Diffstat (limited to 'lib/libesg/Makefile')
-rw-r--r--lib/libesg/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/libesg/Makefile b/lib/libesg/Makefile
new file mode 100644
index 0000000..abb9d4f
--- /dev/null
+++ b/lib/libesg/Makefile
@@ -0,0 +1,27 @@
+# Makefile for linuxtv.org dvb-apps/lib/libesg
+
+includes = types.h
+
+objects = types.o
+
+lib_name = libesg
+
+CPPFLAGS += -I../../lib
+
+.PHONY: all
+
+all: library
+
+include bootstrap/Makefile
+include encapsulation/Makefile
+include representation/Makefile
+include transport/Makefile
+
+.PHONY: $(sub-install)
+
+install:: $(sub-install)
+
+$(sub-install):
+ $(MAKE) -C $@ install
+
+include ../../Make.rules