aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..5d773f1
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,15 @@
+
+noinst_PROGRAMS = libconfig_tests
+
+libconfig_tests_SOURCES = tests.c
+
+libconfig_tests_CPPFLAGS = -I../tinytest -I../lib
+
+libconfig_tests_LDADD = -L../tinytest -ltinytest \
+ -L../lib/.libs -lconfig
+
+
+EXTRA_DIST = \
+ tests.vcproj \
+ testdata/*.cfg \
+ testdata/*.txt