summaryrefslogtreecommitdiffstats
path: root/samples/c/sample1.c
diff options
context:
space:
mode:
Diffstat (limited to 'samples/c/sample1.c')
-rw-r--r--samples/c/sample1.c63
1 files changed, 0 insertions, 63 deletions
diff --git a/samples/c/sample1.c b/samples/c/sample1.c
deleted file mode 100644
index a119c10..0000000
--- a/samples/c/sample1.c
+++ /dev/null
@@ -1,63 +0,0 @@
-/*************************************************************************
- ** Sample1
- ** Load sample.cfg and increment the "X" setting
- *************************************************************************/
-
-#include <stdio.h>
-#include <libconfig.h>
-
-struct config_t cfg;
-
-/***************************************************************************/
-
-int main(int argc, char **argv)
-{
- char *file = "sample.cfg", *var = "x";
-
- if(argc >= 2)
- file = argv[1];
-
- if(argc >= 3)
- var = argv[2];
-
-/* Initialize the configuration */
- config_init(&cfg);
-
- /* Load the file */
- printf("loading [%s]...", file);
- if(!config_read_file(&cfg, file))
- printf("failed\n");
- else
- {
- config_setting_t *setting = NULL;
-
- printf("ok\n");
-
- /* Get the variable setting from the configuration.. */
- printf("increment \"%s\"...", var);
- setting = config_lookup(&cfg, var);
- if(!setting)
- printf("failed\n");
- else
- {
- long x = config_setting_get_int(setting);
- x++;
- config_setting_set_int(setting, x);
- printf("ok (%s=%lu)\n", var, x);
-
- /* Save the changes */
- printf("saving [%s]...", file);
- config_write_file(&cfg, file);
- printf("ok\n");
-
- printf("Done!\n");
- }
- }
-
- /* Free the configuration */
- config_destroy(&cfg);
-
- return 0;
-}
-
-/***************************************************************************/
commit/debian/changelog?id=e4de63418439eb0b60a19db542c6e7e60fc9ebd6&follow=1'>Release 0+git20151202.3864e0a-1debian/0+git20151202.3864e0a-1Jonathan McCrohan1-2/+3 2016-01-18Imported Upstream version 0+git20151202.3864e0aJonathan McCrohan840-4057/+18230 2016-01-18Update get-vcs-snapshot.sh to reflect gbp changesJonathan McCrohan2-1/+2 2016-01-18Imported Upstream version 0+git20151202.3864e0aupstream/0+git20151202.3864e0aJonathan McCrohan840-4057/+18230 2015-05-05d/control: various fixes found by libconfig-model-dpkg-perlJonathan McCrohan2-5/+13 2015-04-01Release 0+git20150208.f2053b3-1Jonathan McCrohan1-2/+2 2015-04-01Describe changes made in snapshotJonathan McCrohan1-0/+3 2015-04-01New Upstream Snapshot (commit f2053b3)Jonathan McCrohan1-0/+6 2015-04-01Imported Upstream version 0+git20150208.f2053b3upstream/0+git20150208.f2053b3Jonathan McCrohan32-333/+483 2014-12-28Release 0+git20141218.b46a22c-1debian/0+git20141218.b46a22c-1Jonathan McCrohan1-2/+2 2014-12-28Updated AU DVB-T files; Thanks Brian Burch! (Closes LP: #1393280)Jonathan McCrohan1-0/+1 2014-12-28New Upstream Snapshot (commit b46a22c)Jonathan McCrohan1-0/+6 2014-12-28Imported Upstream version 0+git20141218.b46a22cupstream/0+git20141218.b46a22cJonathan McCrohan535-639/+317 2014-10-20Release 0+git20141009.d26b627-1debian/0+git20141009.d26b627-1Jonathan McCrohan1-2/+2 2014-10-20Fix up packaging to account for move to DVBv5Jonathan McCrohan2-2/+6 2014-10-20delete d/dtv-scan-files.install; Upstream now supplies a MakefileJonathan McCrohan2-4/+1 2014-10-15d/control: update Standards Version to 3.9.6Jonathan McCrohan2-1/+3 2014-10-15d/control: add Build-Depends on dvb-toolsJonathan McCrohan2-1/+2 2014-10-15New Upstream Snapshot (commit d26b627)Jonathan McCrohan1-0/+10 2014-10-15Imported Upstream version 0+git20141009.d26b627upstream/0+git20141009.d26b627Jonathan McCrohan2010-11120/+159271 2014-07-23Release 0+git20140611.14bd6c7-1debian/0+git20140611.14bd6c7-1Jonathan McCrohan1-2/+2 2014-07-23New Upstream Snapshot (commit 14bd6c7)Jonathan McCrohan1-2/+3 2014-07-23Imported Upstream version 0+git20140611.14bd6c7upstream/0+git20140611.14bd6c7Jonathan McCrohan7-11/+60 2014-05-13New Upstream Snapshot (commit 1246b27)Jonathan McCrohan1-0/+6 2014-05-13Imported Upstream version 0+git20140512.1246b27upstream/0+git20140512.1246b27Jonathan McCrohan391-301/+3983 2014-04-05Release 0+git20140326.cfc2975-1debian/0+git20140326.cfc2975-1Jonathan McCrohan1-2/+2 2014-04-05d/control: update Homepage (upstream has moved from Gitweb to cgit)Jonathan McCrohan2-1/+2 2014-04-05New Upstream Snapshot (commit cfc2975)Jonathan McCrohan1-0/+6 2014-04-05Imported Upstream version 0+git20140326.cfc2975upstream/0+git20140326.cfc2975Jonathan McCrohan118-656/+877 2014-01-16Release 0+git20140107.1850cf8-1debian/0+git20140107.1850cf8-1Jonathan McCrohan1-2/+2 2014-01-16Update Standards Version to 3.9.5Jonathan McCrohan2-1/+9