aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xdebian/rules136
1 files changed, 17 insertions, 119 deletions
diff --git a/debian/rules b/debian/rules
index 2331b8f..931fe85 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,12 +9,14 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+LIBS = $(shell grep '^Package: lib' debian/control | egrep -v '(-doc|-dev)' | sed -e 's@Package: @@' )
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+include /usr/share/quilt/quilt.make
CFLAGS = -Wall -g
@@ -25,13 +27,10 @@ else
endif
# shared library versions, option 1
-version=6.1.1
-major=6
-# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
-#version=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-#major=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+version=8
+major=8
+minor=0
+
config.status: configure
dh_testdir
@@ -39,13 +38,15 @@ config.status: configure
ln -sf /usr/share/misc/config.sub config.sub
test -e config.guess -a -L config.guess || \
ln -sf /usr/share/misc/config.guess config.guess
-
+
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info
CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
+configure: patch
+ $(RM) debian/libconfig8.info debian/shlibs
build: build-stamp
build-stamp: config.status
@@ -54,9 +55,10 @@ build-stamp: config.status
# Add here commands to compile the package.
$(MAKE)
+ $(MAKE) -C doc pdf
touch $@
-clean:
+clean: unpatch
dh_testdir
dh_testroot
@@ -64,7 +66,7 @@ clean:
rm -f build-stamp
- $(RM) config.guess config.sub
+ $(RM) config.guess config.sub config.log
dh_clean
install: build
@@ -75,7 +77,7 @@ install: build
# Add here commands to install the package into debian/tmp
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
-
+ $(RM) .libs/*.la
# Build architecture-independent files here.
binary-indep: build install
@@ -97,116 +99,12 @@ binary-arch: build install
dh_fixperms
# dh_perl
# dh_python
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-# shared library versions, option 1
-version=2.0.5
-major=2
-# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
-#version=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-#major=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
-
-config.status: configure
- dh_testdir
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info \
- CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
-
-
-build: build-stamp
-build-stamp: config.status
- dh_testdir
- $(MAKE)
- $(MAKE) pdf
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- -$(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
-
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+ @for f in $(LIBS); do \
+ echo "makeshlibs -p$$f" ; \
+ dh_makeshlibs -p$$f ; \
+ done
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_python
- dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol