aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/cmake/src
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/cmake/src')
-rw-r--r--contrib/cmake/src/CMakeLists.txt6
-rw-r--r--contrib/cmake/src/main.cpp13
2 files changed, 19 insertions, 0 deletions
diff --git a/contrib/cmake/src/CMakeLists.txt b/contrib/cmake/src/CMakeLists.txt
new file mode 100644
index 0000000..b10b7da
--- /dev/null
+++ b/contrib/cmake/src/CMakeLists.txt
@@ -0,0 +1,6 @@
+PROJECT(libconfig_test_app)
+
+ADD_EXECUTABLE(libconfig_test_app main.cpp)
+
+target_link_libraries(libconfig_test_app config++)
+
diff --git a/contrib/cmake/src/main.cpp b/contrib/cmake/src/main.cpp
new file mode 100644
index 0000000..a563249
--- /dev/null
+++ b/contrib/cmake/src/main.cpp
@@ -0,0 +1,13 @@
+#include <iostream>
+#include <fstream>
+#include <libconfig.h++>
+
+using namespace std;
+using namespace libconfig;
+
+int main ( int argc, char **argv )
+{
+ Config cfg;
+
+ return (0);
+} \ No newline at end of file