aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/Makefile7
-rw-r--r--debian/additions/sample.c++.Makefile15
-rw-r--r--debian/additions/sample.c.Makefile15
-rw-r--r--debian/changelog58
-rw-r--r--debian/compat2
-rw-r--r--debian/control20
-rw-r--r--debian/copyright35
-rw-r--r--debian/dirs1
-rw-r--r--debian/libconfig++9-dev.examples2
-rw-r--r--debian/libconfig++9-dev.install3
-rw-r--r--debian/libconfig9-dev.doc-base9
-rw-r--r--debian/libconfig9-dev.examples2
-rw-r--r--debian/libconfig9-dev.info (renamed from debian/libconfig9.info)0
-rw-r--r--debian/libconfig9-dev.install3
-rw-r--r--debian/libconfig9.install1
-rwxr-xr-xdebian/rules74
-rw-r--r--debian/source/format1
17 files changed, 134 insertions, 114 deletions
diff --git a/debian/Makefile b/debian/Makefile
new file mode 100644
index 0000000..2c4a3b7
--- /dev/null
+++ b/debian/Makefile
@@ -0,0 +1,7 @@
+#
+.PHONY: dummy
+
+
+
+tidy: dummy
+ rm -f *~
diff --git a/debian/additions/sample.c++.Makefile b/debian/additions/sample.c++.Makefile
new file mode 100644
index 0000000..0d9cef2
--- /dev/null
+++ b/debian/additions/sample.c++.Makefile
@@ -0,0 +1,15 @@
+# Makefile for libconfig++ - examples
+
+
+sample1: sample1.cpp
+ $(CC) -o $@ -lconfig++ -lconfig $<
+
+sample2: sample2.cpp
+ $(CC) -o $@ -lconfig++ -lconfig $<
+
+sample3: sample3.cpp
+ $(CC) -o $@ -lconfig++ -lconfig $<
+
+
+stub: stubcpp.cpp
+ $(CC) -o $@ -lconfig++ -lconfig $<
diff --git a/debian/additions/sample.c.Makefile b/debian/additions/sample.c.Makefile
new file mode 100644
index 0000000..bf2f8f5
--- /dev/null
+++ b/debian/additions/sample.c.Makefile
@@ -0,0 +1,15 @@
+# Makefile for libconfig - examples
+
+
+sample1: sample1.c
+ $(CC) -o $@ -lconfig $<
+
+sample2: sample2.c
+ $(CC) -o $@ -lconfig $<
+
+sample3: sample3.c
+ $(CC) -o $@ -lconfig $<
+
+
+stub: stub.c
+ $(CC) -o $@ -lconfig $<
diff --git a/debian/changelog b/debian/changelog
index 965c09b..eb5badb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,18 +1,33 @@
-libconfig (1.4) unstable; urgency=low
+libconfig (1.4.8-1) unstable; urgency=low
- * new upstream release
- * libconfig++9-dev no longer depends on libconfig9-dev
+ * Non-maintainer upload.
+ * New upstream release.
+ - soname bump to 9
+ - update to S-V 3.9.2 with no changes
- -- Mark Lindner <hyperrealm@gmail.com> Fri, 21 Aug 2009 00:00:00 +0800
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Thu, 01 Dec 2011 23:14:41 +0000
-libconfig (1.3.2) unstable; urgency=low
+libconfig (1.3.2-2) unstable; urgency=low
- * new upstream release
- * use official Debian files as basis
- * libconfig++8-dev depends on libconfig8-dev because libconfig.h++
- includes libconfig.h which is in libconfig8-dev
+ * Removed "conflicts" with older sonames (Closes: #536635)
+ * Added missing compile-time libconfig++8-dev dependencies
+ (libconfig8-dev) (Closes: #537311)
- -- Klaus Schneider <kschn@users.sourceforge.net> Wed, 18 Feb 2009 15:26:32 +0100
+ * Removed libtool's ".la" files (clients should use pkg-config)
+
+ * Updated to S-V 3.8.3 with no changes
+
+ * With many thanks to Christian Hammers, who kindly checked the package.
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Sun, 13 Sep 2009 04:25:14 +0200
+
+libconfig (1.3.2-1) unstable; urgency=low
+
+ * New upstream release (Closes: #521725)
+ - soname bump to 8
+ - Updated to S-V 3.8.1 with no changes
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Tue, 07 Apr 2009 21:13:16 +0200
libconfig (1.3.1-1) unstable; urgency=low
@@ -44,26 +59,3 @@ libconfig (0.9-1) unstable; urgency=low
-- Jose Luis Tallon <jltallon@adv-solutions.net> Tue, 10 Oct 2006 01:42:09 +0200
-libconfigduo (1.3.1) unstable; urgency=low
-
- * Release 1.3.1
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Thu, 13 Nov 2008 17:05:12 +0100
-
-libconfigduo (1.3) unstable; urgency=low
-
- * Release 1.3
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Fri, 4 Apr 2008 09:36:42 +0200
-
-libconfigduo (1.2.1-1) unstable; urgency=low
-
- * Release 1.2.1
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Thu, 31 Jan 2008 11:25:21 +0100
-
-libconfigduo (1.1.1-1) unstable; urgency=low
-
- * Initial release
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Mon, 25 Jun 2007 16:21:56 +0200
diff --git a/debian/compat b/debian/compat
index 7ed6ff8..7f8f011 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-5
+7
diff --git a/debian/control b/debian/control
index fdc0a8c..21a2a45 100644
--- a/debian/control
+++ b/debian/control
@@ -1,9 +1,8 @@
Source: libconfig
Priority: optional
-Maintainer: Klaus Schneider <kschn@users.sourceforge.net>
-Uploaders: Julien Danjou <acid@debian.org>
-Build-Depends: debhelper (>= 5), autotools-dev, texinfo
-Standards-Version: 3.8.0
+Maintainer: Jose Luis Tallon <jltallon@adv-solutions.net>
+Build-Depends: debhelper (>= 5), autotools-dev, texinfo, texlive, ghostscript, quilt
+Standards-Version: 3.9.2
Homepage: http://www.hyperrealm.com/libconfig/
Section: libs
@@ -39,9 +38,9 @@ Package: libconfig9-dev
Section: libdevel
Architecture: any
Provides: libconfig-dev
-Depends: libconfig9 (= ${binary:Version}), pkg-config (>= 0.20)
-Conflicts: libconfigduo6-dev, libconfig6-dev
-Description: processing of structured config files (development)
+Depends: libconfig9 (= ${binary:Version}), pkg-config (>= 0.20), ${misc:Depends}
+Conflicts: libconfig8-dev
+Description: parsing and manipulation of structured config files(development)
This library features a fully reentrant parser and includes bindings for
both the C and C++ programming languages. It runs on modern POSIX-compliant
systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
@@ -63,9 +62,10 @@ Package: libconfig++9-dev
Section: libdevel
Architecture: any
Provides: libconfig++-dev
-Depends: libconfig++9 (= ${binary:Version}), libconfig9 (= ${binary:Version}), pkg-config (>= 0.20)
-Conflicts: libconfigduo6-dev, libconfig++6-dev
-Description: processing of structured config files (C++ development)
+Depends: libconfig++9 (= ${binary:Version}), libconfig-dev,
+ pkg-config (>= 0.20), ${misc:Depends}
+Conflicts: libconfig++8-dev
+Description: parsing and manipulation of structured config files(C++ development)
This library features a fully reentrant parser and includes bindings for
both the C and C++ programming languages. It runs on modern POSIX-compliant
systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
diff --git a/debian/copyright b/debian/copyright
index e6e57d0..c8a9482 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -30,36 +30,5 @@ On Debian systems, the full text of GNU's Lesser General Public License can
be found at /usr/share/common-licenses/LGPL-2.1
-The Debian packaging is (C) 2006-2008, Jose Luis Tallon <jltallon@adv-solutions.net>
-and is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
-This package was debianized by Klaus Schneider <kschn@users.sourceforge.net> on
-Mon, 25 Jun 2007 16:21:56 +0200.
-
-It was downloaded from http://www.hyperrealm.com/libconfig/libconfig.html
-
-Upstream Author: Mark A. Lindner
-
-Copyright: (c) 2005-2009 Mark A. Lindner
-
-License:
-
- This package is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2 of the License, or (at your option) any later version.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-On Debian systems, the complete text of the GNU Lesser General
-Public License can be found in `/usr/share/common-licenses/LGPL'.
-
-
-The Debian packaging is (C) 2007, Klaus Schneider <kschn@users.sourceforge.net> and
-is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
+The Debian packaging is (C) 2006-2009, Jose Luis Tallon <jltallon@adv-solutions.net>
+and is licensed under the GPL version 2, see `/usr/share/common-licenses/GPL-2'.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..6845771
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1 @@
+usr/lib
diff --git a/debian/libconfig++9-dev.examples b/debian/libconfig++9-dev.examples
new file mode 100644
index 0000000..b2c7675
--- /dev/null
+++ b/debian/libconfig++9-dev.examples
@@ -0,0 +1,2 @@
+samples/c++/*.cpp
+debian/additions/sample.c++.Makefile
diff --git a/debian/libconfig++9-dev.install b/debian/libconfig++9-dev.install
index 642348a..a6f027b 100644
--- a/debian/libconfig++9-dev.install
+++ b/debian/libconfig++9-dev.install
@@ -1,5 +1,4 @@
debian/tmp/usr/include/libconfig.h++
debian/tmp/usr/lib/libconfig++.a
debian/tmp/usr/lib/libconfig++.so
-debian/tmp/usr/lib/libconfig++.la
-debian/tmp/usr/lib/pkgconfig/libconfig++.pc
+libconfig++.pc usr/lib/pkgconfig
diff --git a/debian/libconfig9-dev.doc-base b/debian/libconfig9-dev.doc-base
new file mode 100644
index 0000000..ef7cecc
--- /dev/null
+++ b/debian/libconfig9-dev.doc-base
@@ -0,0 +1,9 @@
+Document: libconfig9
+Title: libconfig manual
+Author: Mark A Lindner
+Abstract: This manual describes what libconfig is
+ and how it can be used to parse configuration files
+Section: Programming/C
+
+Format: PDF
+Files: /usr/share/doc/libconfig9-dev/libconfig.pdf.gz
diff --git a/debian/libconfig9-dev.examples b/debian/libconfig9-dev.examples
new file mode 100644
index 0000000..306ccd5
--- /dev/null
+++ b/debian/libconfig9-dev.examples
@@ -0,0 +1,2 @@
+samples/c/*.c
+debian/additions/sample.c.Makefile \ No newline at end of file
diff --git a/debian/libconfig9.info b/debian/libconfig9-dev.info
index 628d7f3..628d7f3 100644
--- a/debian/libconfig9.info
+++ b/debian/libconfig9-dev.info
diff --git a/debian/libconfig9-dev.install b/debian/libconfig9-dev.install
index 5b5ce02..ede86d5 100644
--- a/debian/libconfig9-dev.install
+++ b/debian/libconfig9-dev.install
@@ -1,5 +1,4 @@
debian/tmp/usr/include/libconfig.h
debian/tmp/usr/lib/libconfig.a
debian/tmp/usr/lib/libconfig.so
-debian/tmp/usr/lib/libconfig.la
-debian/tmp/usr/lib/pkgconfig/libconfig.pc
+libconfig.pc usr/lib/pkgconfig
diff --git a/debian/libconfig9.install b/debian/libconfig9.install
index aba7b37..b73360c 100644
--- a/debian/libconfig9.install
+++ b/debian/libconfig9.install
@@ -1,2 +1 @@
debian/tmp/usr/lib/libconfig.so.9*
-
diff --git a/debian/rules b/debian/rules
index d758c24..c07a422 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,12 +9,14 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+LIBS = $(shell grep '^Package: lib' debian/control | egrep -v '(-doc|-dev)' | sed -e 's@Package: @@' )
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+include /usr/share/quilt/quilt.make
CFLAGS = -Wall -g
@@ -24,45 +26,58 @@ else
CFLAGS += -O2
endif
-# shared library versions
-version=`ls lib/.libs/lib*.so.* | \
- awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-major=`ls lib/.libs/lib*.so.* | \
- awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+# shared library versions, option 1
+version=9
+major=9
+minor=0
+
config.status: configure
dh_testdir
+ test -e config.sub -a -L config.sub || \
+ ln -sf /usr/share/misc/config.sub config.sub
+ test -e config.guess -a -L config.guess || \
+ ln -sf /usr/share/misc/config.guess config.guess
+
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info \
- CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
+ --prefix=/usr \
+ --mandir=\$${prefix}/share/man \
+ --infodir=\$${prefix}/share/info
+ CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
+
+configure: patch
+ $(RM) debian/libconfig8.info debian/shlibs
build: build-stamp
build-stamp: config.status
dh_testdir
+
+ # Add here commands to compile the package.
$(MAKE)
- $(MAKE) pdf
+
+ $(MAKE) -C doc pdf
touch $@
-clean:
+clean: unpatch
dh_testdir
dh_testroot
+
+ [ ! -f Makefile ] || $(MAKE) distclean
+
rm -f build-stamp
- -$(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
- dh_clean
+
+ $(RM) config.guess config.sub config.log
+ dh_clean
install: build
dh_testdir
dh_testroot
- dh_clean -k
+ dh_clean -k
dh_installdirs
- $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+ # Add here commands to install the package into debian/tmp
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+ $(RM) .libs/*.la
# Build architecture-independent files here.
binary-indep: build install
@@ -76,17 +91,7 @@ binary-arch: build install
dh_installdocs
dh_installexamples
dh_install
- dh_strip -v --package=libconfig9 --dbg-package=libconfig9-dbg
- dh_strip -v --package=libconfig++9 --dbg-package=libconfig++9-dbg
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
+ dh_installinfo
dh_installman
dh_link
dh_strip
@@ -94,7 +99,12 @@ binary-arch: build install
dh_fixperms
# dh_perl
# dh_python
- dh_makeshlibs
+
+ @for f in $(LIBS); do \
+ echo "makeshlibs -p$$f" ; \
+ dh_makeshlibs -p$$f ; \
+ done
+
dh_installdeb
dh_shlibdeps
dh_gencontrol
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)