aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libconfig.vcproj
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2011-12-01 23:47:41 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2011-12-01 23:47:41 +0000
commit1eaceca55c7e62892fd28bfbb5fc03240a48cee3 (patch)
tree7243fcd09c57e06e72b15f0044fd2c77babd7843 /lib/libconfig.vcproj
parentd4b5ddf4bcacd692011f5a597025c38a1262d6ca (diff)
parent429e46051dba814e7d6c74368eb1bba550222cbe (diff)
downloadlibconfig-1eaceca55c7e62892fd28bfbb5fc03240a48cee3.tar.gz
Merge commit 'upstream/1.4.8'
Conflicts: debian/changelog debian/control debian/libconfig++9-dev.install debian/libconfig8.install debian/libconfig9-dev.install debian/rules
Diffstat (limited to '')
-rw-r--r--lib/libconfig.vcproj (renamed from libconfig.vcproj)40
1 files changed, 26 insertions, 14 deletions
diff --git a/libconfig.vcproj b/lib/libconfig.vcproj
index 219f694..90a520e 100644
--- a/libconfig.vcproj
+++ b/lib/libconfig.vcproj
@@ -1,10 +1,11 @@
<?xml version="1.0" encoding="Windows-1252"?>
<VisualStudioProject
ProjectType="Visual C++"
- Version="8.00"
+ Version="9.00"
Name="libconfig"
ProjectGUID="{1A234565-926D-49B2-83E4-D56E0C38C9F2}"
RootNamespace="libconfig"
+ TargetFrameworkVersion="131072"
>
<Platforms>
<Platform
@@ -38,7 +39,7 @@
<Tool
Name="VCCLCompilerTool"
AdditionalIncludeDirectories=""
- PreprocessorDefinitions="WIN32;_DEBUG;_WINDOWS;_USRDLL;LIBCONFIG_EXPORTS;YY_NO_UNISTD_H"
+ PreprocessorDefinitions="LIBCONFIG_EXPORTS;YY_NO_UNISTD_H;YY_USE_CONST;WIN32;_DEBUG;_WINDOWS;_USRDLL"
RuntimeLibrary="3"
CompileAs="1"
/>
@@ -53,9 +54,12 @@
/>
<Tool
Name="VCLinkerTool"
+ OutputFile="$(OutDir)\$(ProjectName)_d.dll"
GenerateDebugInformation="true"
GenerateMapFile="true"
MapExports="true"
+ RandomizedBaseAddress="1"
+ DataExecutionPrevention="0"
/>
<Tool
Name="VCALinkTool"
@@ -76,9 +80,6 @@
Name="VCAppVerifierTool"
/>
<Tool
- Name="VCWebDeploymentTool"
- />
- <Tool
Name="VCPostBuildEventTool"
/>
</Configuration>
@@ -105,7 +106,7 @@
/>
<Tool
Name="VCCLCompilerTool"
- PreprocessorDefinitions="LIBCONFIG_EXPORTS;YY_NO_UNISTD_H;_CRT_SECURE_NO_DEPRECATE"
+ PreprocessorDefinitions="LIBCONFIG_EXPORTS;YY_NO_UNISTD_H;YY_USE_CONST;_CRT_SECURE_NO_DEPRECATE;_STDLIB_H"
RuntimeLibrary="2"
CompileAs="1"
/>
@@ -120,6 +121,8 @@
/>
<Tool
Name="VCLinkerTool"
+ RandomizedBaseAddress="1"
+ DataExecutionPrevention="0"
/>
<Tool
Name="VCALinkTool"
@@ -140,9 +143,6 @@
Name="VCAppVerifierTool"
/>
<Tool
- Name="VCWebDeploymentTool"
- />
- <Tool
Name="VCPostBuildEventTool"
/>
</Configuration>
@@ -164,9 +164,17 @@
>
</File>
<File
+ RelativePath=".\scanctx.c"
+ >
+ </File>
+ <File
RelativePath=".\scanner.c"
>
</File>
+ <File
+ RelativePath=".\strbuf.c"
+ >
+ </File>
</Filter>
<Filter
Name="Header Files"
@@ -174,19 +182,19 @@
UniqueIdentifier="{93995380-89BD-4b04-88EB-625FBE52EBFB}"
>
<File
- RelativePath=".\ac_config.h"
+ RelativePath="..\ac_config.h"
>
</File>
<File
- RelativePath=".\config.tab.h"
+ RelativePath=".\grammar.h"
>
</File>
<File
- RelativePath=".\grammar.h"
+ RelativePath=".\libconfig.h"
>
</File>
<File
- RelativePath=".\libconfig.h"
+ RelativePath=".\parsectx.h"
>
</File>
<File
@@ -194,7 +202,7 @@
>
</File>
<File
- RelativePath=".\resource.h"
+ RelativePath=".\scanctx.h"
>
</File>
<File
@@ -202,6 +210,10 @@
>
</File>
<File
+ RelativePath=".\win32\stdint.h"
+ >
+ </File>
+ <File
RelativePath=".\wincompat.h"
>
</File>