aboutsummaryrefslogtreecommitdiffstats
path: root/aux-build/mkinstalldirs
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-11-17 17:04:05 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-11-17 17:04:05 +0000
commit2fc13f629ad1d5f991ac3679e9d399760ceef085 (patch)
treeb267e6b0bacca43f0563a12d9b2a3efb51feaf61 /aux-build/mkinstalldirs
parentc317fac1d7221e4a278c41490ff300f7802e9dcb (diff)
parentf2499612c5594944d3e0891259859668d35c85b2 (diff)
downloadlibconfig-2fc13f629ad1d5f991ac3679e9d399760ceef085.tar.gz
Merge tag 'upstream/1.4.9'
Upstream version 1.4.9 Conflicts: debian/changelog debian/control libconfig.spec
Diffstat (limited to 'aux-build/mkinstalldirs')
-rwxr-xr-xaux-build/mkinstalldirs28
1 files changed, 20 insertions, 8 deletions
diff --git a/aux-build/mkinstalldirs b/aux-build/mkinstalldirs
index 5d26a48..4191a45 100755
--- a/aux-build/mkinstalldirs
+++ b/aux-build/mkinstalldirs
@@ -1,7 +1,7 @@
#! /bin/sh
# mkinstalldirs --- make directory hierarchy
-scriptversion=2005-02-02.21
+scriptversion=2009-04-28.21; # UTC
# Original author: Noah Friedman <friedman@prep.ai.mit.edu>
# Created: 1993-05-16
@@ -11,8 +11,11 @@ scriptversion=2005-02-02.21
# bugs to <bug-automake@gnu.org> or send patches to
# <automake-patches@gnu.org>.
+nl='
+'
+IFS=" "" $nl"
errstatus=0
-dirmode=""
+dirmode=
usage="\
Usage: mkinstalldirs [-h] [--help] [--version] [-m MODE] DIR ...
@@ -103,13 +106,21 @@ esac
for file
do
- set fnord `echo ":$file" | sed -ne 's/^:\//#/;s/^://;s/\// /g;s/^#/\//;p'`
+ case $file in
+ /*) pathcomp=/ ;;
+ *) pathcomp= ;;
+ esac
+ oIFS=$IFS
+ IFS=/
+ set fnord $file
shift
+ IFS=$oIFS
- pathcomp=
for d
do
- pathcomp="$pathcomp$d"
+ test "x$d" = x && continue
+
+ pathcomp=$pathcomp$d
case $pathcomp in
-*) pathcomp=./$pathcomp ;;
esac
@@ -124,7 +135,7 @@ do
else
if test ! -z "$dirmode"; then
echo "chmod $dirmode $pathcomp"
- lasterr=""
+ lasterr=
chmod "$dirmode" "$pathcomp" || lasterr=$?
if test ! -z "$lasterr"; then
@@ -134,7 +145,7 @@ do
fi
fi
- pathcomp="$pathcomp/"
+ pathcomp=$pathcomp/
done
done
@@ -146,5 +157,6 @@ exit $errstatus
# eval: (add-hook 'write-file-hooks 'time-stamp)
# time-stamp-start: "scriptversion="
# time-stamp-format: "%:y-%02m-%02d.%02H"
-# time-stamp-end: "$"
+# time-stamp-time-zone: "UTC"
+# time-stamp-end: "; # UTC"
# End: