aboutsummaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xconfigure6
-rw-r--r--configure.in1
2 files changed, 6 insertions, 1 deletions
diff --git a/configure b/configure
index e87748c..caea080 100755
--- a/configure
+++ b/configure
@@ -8120,7 +8120,11 @@ echo "$as_me: WARNING: X11 headers or libraries not available: X11 driver disabl
else
GRAPHIC="yes"
DRIVERS="$DRIVERS drv_X11.o"
- DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ if test "x$ac_x_libraries" = "x"; then
+ DRVLIBS="$DRVLIBS -lX11"
+ else
+ DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ fi
CPP_FLAGS="$CPPFLAGS $X_CFLAGS"
cat >>confdefs.h <<\_ACEOF
diff --git a/configure.in b/configure.in
index ca233da..17dd4c5 100644
--- a/configure.in
+++ b/configure.in
@@ -46,6 +46,7 @@ sinclude(curses.m4)
AC_CHECK_CURSES
# Checks for X11
+AC_PATH_X
AC_PATH_XTRA
# double-check for X11
if test "$no_x" != "yes"; then