aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.in18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 45399f6..2a22440 100644
--- a/configure.in
+++ b/configure.in
@@ -1,14 +1,14 @@
+# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
AC_INIT([LCD4Linux],[0.99],[reinelt@eunet.at])
AC_CONFIG_SRCDIR([lcd4linux.c])
AM_INIT_AUTOMAKE(lcd4linux,0.99)
AM_CONFIG_HEADER(config.h)
# Checks for programs.
-AC_PROG_AWK
AC_PROG_CC
-AC_PROG_INSTALL
-AC_PROG_LN_S
# Checks for libraries.
AC_CHECK_LIB(m, log)
@@ -224,9 +224,8 @@ AC_SUBST(DRVLIBS)
# Checks for header files.
AC_HEADER_STDC
-AC_HEADER_DIRENT
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/ioctl.h sys/time.h syslog.h unistd.h)
+AC_CHECK_HEADERS([fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h termios.h unistd.h])
AC_CHECK_HEADERS(sys/io.h asm/io.h)
AC_CHECK_HEADERS(linux/parport.h linux/ppdev.h)
AC_CHECK_HEADERS(gd/gd.h gd.h)
@@ -239,14 +238,19 @@ AC_C_INLINE
AC_TYPE_PID_T
AC_TYPE_SIZE_T
AC_HEADER_TIME
-AC_STRUCT_TM
AC_TYPE_UID_T
# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_FORK
AC_PROG_GCC_TRADITIONAL
+AC_FUNC_MALLOC
AC_FUNC_MEMCMP
+AC_FUNC_REALLOC
+AC_FUNC_SELECT_ARGTYPES
AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(gettimeofday putenv select socket strdup strerror strstr strtol uname)
+AC_FUNC_STAT
+AC_CHECK_FUNCS([atexit dup2 gethostbyname gettimeofday memset putenv select socket strcasecmp strchr strdup strerror strpbrk strrchr strstr strtol uname])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT