aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 23738b7..eebbefa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,9 +11,6 @@ AM_CFLAGS = $(X_CFLAGS) -D_GNU_SOURCE -Wall
lcd4linux_LDFLAGS = $(X_LIBS)
lcd4linux_LDADD = liblcd4linux.la @DRVLIBS@
-# Fixme: if this line is active, all drivers will be compiled in
-# and not taken from the library
-# lcd4linux_DEPENDENCIES = @DRIVERS@
lcd4linux_SOURCES = \
lcd4linux.c \
@@ -34,9 +31,9 @@ exec.c exec.h \
mail2.c \
socket.c socket.h
+liblcd4linux_la_DEPENDENCIES = @DRIVERS@
liblcd4linux_la_LDFLAGS = -version-info 9:11:9
-# Fixme: why? Why not?
-# liblcd4linux_la_LIBADD=$(DRIVERS)
+liblcd4linux_la_LIBADD = @DRIVERS@
liblcd4linux_la_SOURCES = \
display.c display.h \
@@ -47,11 +44,7 @@ pixmap.c pixmap.h \
bar.c bar.h \
icon.c icon.h \
fontmap.c fontmap.h \
-udelay.c udelay.h \
-@DRIVERS@
-# Fixme: wwhy? why not?
-# Fixme: $DRIVERS? S(DRIVERS)? @DRIVERS@?
-
+udelay.c udelay.h
EXTRA_lcd4linux_SOURCES= \
parport.c parport.h \