aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am39
1 files changed, 21 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index f7702e2..1889b16 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,25 +1,28 @@
## Process this file with automake to produce Makefile.in
AUTOMAKE_OPTIONS = foreign
-
CLEANFILES = *~
-AM_CFLAGS = -Wall
-LDFLAGS = -L/usr/X11R6/lib
-LDADD = -lX11
bin_PROGRAMS = lcd4linux
+
+AM_CFLAGS = $(X_CFLAGS) -Wall
+lcd4linux_LDFLAGS = $(X_LIBS)
+if WITH_X
+lcd4linux_LDADD = -lX11
+endif
+
lcd4linux_SOURCES = \
- lcd4linux.c \
- cfg.c cfg.h \
- parser.c parser.h \
- processor.c processor.h \
- system.c system.h \
- isdn.c isdn.h \
- filter.c filter.h \
- display.c display.h \
- pixmap.c pixmap.h \
- fontmap.c fontmap.h \
- Skeleton.c \
- MatrixOrbital.c \
- Raster.c \
- XWindow.c
+lcd4linux.c \
+cfg.c cfg.h \
+parser.c parser.h \
+processor.c processor.h \
+system.c system.h \
+isdn.c isdn.h \
+filter.c filter.h \
+display.c display.h \
+pixmap.c pixmap.h \
+fontmap.c fontmap.h \
+Skeleton.c \
+MatrixOrbital.c \
+Raster.c \
+XWindow.c