aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am3
-rw-r--r--Makefile.in6
-rw-r--r--config.h.in3
-rwxr-xr-xconfigure35
-rw-r--r--configure.in4
-rw-r--r--drivers.m411
-rw-r--r--drv.c14
7 files changed, 23 insertions, 53 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c10ccd..6825419 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -67,7 +67,6 @@ drv_T6963.c \
drv_USBLCD.c \
drv_MatrixOrbital.c \
MilfordInstruments.c \
-PalmPilot.c \
drv_X11.c \
Text.c \
font_6x8.h \
@@ -106,8 +105,6 @@ FAQ \
NEWS \
TODO \
README \
-README.Rows \
-README.Tokens \
README.Drivers \
README.Plugins \
README.KDE \
diff --git a/Makefile.in b/Makefile.in
index 7f23768..84b1a20 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -101,10 +101,10 @@ lcd4linux_SOURCES = lcd4linux.c cfg.c cfg.h deb
#liblcd4linux_la_SOURCES =
-EXTRA_lcd4linux_SOURCES = drv_generic_text.c drv_generic_text.h drv_generic_graphic.c drv_generic_graphic.h drv_generic_serial.c drv_generic_serial.h drv_generic_parport.c drv_generic_parport.h BeckmannEgle.c drv_Crystalfontz.c drv_Cwlinux.c drv_HD44780.c drv_Image.c drv_M50530.c drv_T6963.c drv_USBLCD.c drv_MatrixOrbital.c MilfordInstruments.c PalmPilot.c drv_X11.c Text.c font_6x8.h plugin_apm.c plugin_cpuinfo.c plugin_dvb.c plugin_exec.c plugin_i2c_sensors.c plugin_imon.c plugin_isdn.c plugin_loadavg.c plugin_meminfo.c plugin_mysql.c plugin_netdev.c plugin_pop3.c plugin_ppp.c plugin_proc_stat.c plugin_seti.c plugin_uname.c plugin_uptime.c plugin_wireless.c plugin_xmms.c
+EXTRA_lcd4linux_SOURCES = drv_generic_text.c drv_generic_text.h drv_generic_graphic.c drv_generic_graphic.h drv_generic_serial.c drv_generic_serial.h drv_generic_parport.c drv_generic_parport.h BeckmannEgle.c drv_Crystalfontz.c drv_Cwlinux.c drv_HD44780.c drv_Image.c drv_M50530.c drv_T6963.c drv_USBLCD.c drv_MatrixOrbital.c MilfordInstruments.c drv_X11.c Text.c font_6x8.h plugin_apm.c plugin_cpuinfo.c plugin_dvb.c plugin_exec.c plugin_i2c_sensors.c plugin_imon.c plugin_isdn.c plugin_loadavg.c plugin_meminfo.c plugin_mysql.c plugin_netdev.c plugin_pop3.c plugin_ppp.c plugin_proc_stat.c plugin_seti.c plugin_uname.c plugin_uptime.c plugin_wireless.c plugin_xmms.c
-EXTRA_DIST = lcd4linux.conf.sample lcd4kde.conf lcd4linux.kdelnk lcd4linux.xpm lcd4linux.lsm curses.m4 AUTHORS CREDITS FAQ NEWS TODO README README.Rows README.Tokens README.Drivers README.Plugins README.KDE plugin_sample.c
+EXTRA_DIST = lcd4linux.conf.sample lcd4kde.conf lcd4linux.kdelnk lcd4linux.xpm lcd4linux.lsm curses.m4 AUTHORS CREDITS FAQ NEWS TODO README README.Drivers README.Plugins README.KDE plugin_sample.c
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
@@ -140,7 +140,7 @@ DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
TAR = tar
GZIP_ENV = --best
DEP_FILES = .deps/BeckmannEgle.P .deps/MilfordInstruments.P \
-.deps/PalmPilot.P .deps/Text.P .deps/cfg.P .deps/debug.P .deps/drv.P \
+.deps/Text.P .deps/cfg.P .deps/debug.P .deps/drv.P \
.deps/drv_Crystalfontz.P .deps/drv_Cwlinux.P .deps/drv_HD44780.P \
.deps/drv_Image.P .deps/drv_M50530.P .deps/drv_MatrixOrbital.P \
.deps/drv_T6963.P .deps/drv_USBLCD.P .deps/drv_X11.P \
diff --git a/config.h.in b/config.h.in
index b1e163f..2831ddd 100644
--- a/config.h.in
+++ b/config.h.in
@@ -344,9 +344,6 @@
/* Milford Instruments driver */
#undef WITH_MILINST
-/* PalmPilot driver */
-#undef WITH_PALMPILOT
-
/* driver */
#undef WITH_PNG
diff --git a/configure b/configure
index 35b07fa..05ef2d0 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.59 for LCD4Linux 0.10.0.
+# Generated by GNU Autoconf 2.59 for LCD4Linux 0.10.0-RC1.
#
# Report bugs to <reinelt@eunet.at>.
#
@@ -269,8 +269,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='LCD4Linux'
PACKAGE_TARNAME='lcd4linux'
-PACKAGE_VERSION='0.10.0'
-PACKAGE_STRING='LCD4Linux 0.10.0'
+PACKAGE_VERSION='0.10.0-RC1'
+PACKAGE_STRING='LCD4Linux 0.10.0-RC1'
PACKAGE_BUGREPORT='reinelt@eunet.at'
ac_unique_file="lcd4linux.c"
@@ -780,7 +780,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures LCD4Linux 0.10.0 to adapt to many kinds of systems.
+\`configure' configures LCD4Linux 0.10.0-RC1 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -846,7 +846,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of LCD4Linux 0.10.0:";;
+ short | recursive ) echo "Configuration of LCD4Linux 0.10.0-RC1:";;
esac
cat <<\_ACEOF
@@ -869,7 +869,7 @@ Optional Packages:
possible drivers are:
BeckmannEgle, CrystalFontz, Curses, Cwlinux,
HD44780, M50530, T6963, USBLCD, MatrixOrbital,
- MilfordInstruments, PalmPilot, PNG, PPM, X11
+ MilfordInstruments, PNG, PPM, X11
--with-plugins=<list> choose which plugins to compile.
type --with-plugins=list for a list
of avaible plugins
@@ -982,7 +982,7 @@ fi
test -n "$ac_init_help" && exit 0
if $ac_init_version; then
cat <<\_ACEOF
-LCD4Linux configure 0.10.0
+LCD4Linux configure 0.10.0-RC1
generated by GNU Autoconf 2.59
Copyright (C) 2003 Free Software Foundation, Inc.
@@ -996,7 +996,7 @@ cat >&5 <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by LCD4Linux $as_me 0.10.0, which was
+It was created by LCD4Linux $as_me 0.10.0-RC1, which was
generated by GNU Autoconf 2.59. Invocation command line was
$ $0 $@
@@ -1528,7 +1528,7 @@ fi
PACKAGE=lcd4linux
-VERSION=0.10.0
+VERSION=0.10.0-RC1
if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
{ { echo "$as_me:$LINENO: error: source directory already configured; run \"make distclean\" there first" >&5
@@ -5455,9 +5455,6 @@ for driver in $drivers; do
MilfordInstruments)
MILINST=$val
;;
- PalmPilot)
- PALMPILOT=$val
- ;;
PNG)
PNG=$val
;;
@@ -5604,16 +5601,6 @@ _ACEOF
fi
-if test "$PALMPILOT" = "yes"; then
-# DRIVERS="$DRIVERS PalmPilot.lo"
-# DRIVERS="$DRIVERS PalmPilot.o"
-
-cat >>confdefs.h <<\_ACEOF
-#define WITH_PALMPILOT 1
-_ACEOF
-
-fi
-
if test "$PNG" = "yes"; then
if test "$has_gd" = "true"; then
GRAPHIC="yes"
@@ -10202,7 +10189,7 @@ _ASBOX
} >&5
cat >&5 <<_CSEOF
-This file was extended by LCD4Linux $as_me 0.10.0, which was
+This file was extended by LCD4Linux $as_me 0.10.0-RC1, which was
generated by GNU Autoconf 2.59. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -10265,7 +10252,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-LCD4Linux config.status 0.10.0
+LCD4Linux config.status 0.10.0-RC1
configured by $0, generated by GNU Autoconf 2.59,
with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
diff --git a/configure.in b/configure.in
index bb9b926..b5679e6 100644
--- a/configure.in
+++ b/configure.in
@@ -2,9 +2,9 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([LCD4Linux],[0.10.0],[reinelt@eunet.at])
+AC_INIT([LCD4Linux],[0.10.0-RC1],[reinelt@eunet.at])
AC_CONFIG_SRCDIR([lcd4linux.c])
-AM_INIT_AUTOMAKE([lcd4linux],0.10.0)
+AM_INIT_AUTOMAKE([lcd4linux],0.10.0-RC1)
AM_CONFIG_HEADER(config.h)
# Checks for programs.
diff --git a/drivers.m4 b/drivers.m4
index 47e1600..e1c84f7 100644
--- a/drivers.m4
+++ b/drivers.m4
@@ -11,7 +11,7 @@ AC_ARG_WITH(
[ possible drivers are:]
[ BeckmannEgle, CrystalFontz, Curses, Cwlinux,]
[ HD44780, M50530, T6963, USBLCD, MatrixOrbital,]
- [ MilfordInstruments, PalmPilot, PNG, PPM, X11],
+ [ MilfordInstruments, PNG, PPM, X11],
drivers=$withval,
drivers=all
)
@@ -77,9 +77,6 @@ for driver in $drivers; do
MilfordInstruments)
MILINST=$val
;;
- PalmPilot)
- PALMPILOT=$val
- ;;
PNG)
PNG=$val
;;
@@ -182,12 +179,6 @@ if test "$MILINST" = "yes"; then
AC_DEFINE(WITH_MILINST,1,[Milford Instruments driver])
fi
-if test "$PALMPILOT" = "yes"; then
-# DRIVERS="$DRIVERS PalmPilot.lo"
-# DRIVERS="$DRIVERS PalmPilot.o"
- AC_DEFINE(WITH_PALMPILOT,1,[PalmPilot driver])
-fi
-
if test "$PNG" = "yes"; then
if test "$has_gd" = "true"; then
GRAPHIC="yes"
diff --git a/drv.c b/drv.c
index 4904551..39928f9 100644
--- a/drv.c
+++ b/drv.c
@@ -1,4 +1,4 @@
-/* $Id: drv.c,v 1.10 2004/05/25 14:26:29 reinelt Exp $
+/* $Id: drv.c,v 1.11 2004/05/25 19:54:15 reinelt Exp $
*
* new framework for display drivers
*
@@ -23,6 +23,11 @@
*
*
* $Log: drv.c,v $
+ * Revision 1.11 2004/05/25 19:54:15 reinelt
+ *
+ * 'make distcheck' bugs fixed
+ * release number changed to 0.10.0-RC1
+ *
* Revision 1.10 2004/05/25 14:26:29 reinelt
*
* added "Image" driver (was: Raster.c) for PPM and PNG creation
@@ -123,7 +128,6 @@ extern DRIVER drv_T6963;
extern DRIVER drv_USBLCD;
extern DRIVER drv_MatrixOrbital;
extern DRIVER drv_MilfordInstruments;
-extern DRIVER drv_PalmPilot;
extern DRIVER drv_X11;
extern DRIVER drv_Text;
@@ -163,15 +167,9 @@ DRIVER *Driver[] = {
&drv_USBLCD,
#endif
/* Fixme
- #ifdef WITH_MATRIXORBITAL
- &MatrixOrbital,
- #endif
#ifdef WITH_MILINST
&MilfordInstruments,
#endif
- #ifdef WITH_PALMPILOT
- &PalmPilot,
- #endif
*/
#ifdef WITH_X11
&drv_X11,