aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am1
-rw-r--r--Makefile.in2
-rw-r--r--acconfig.h33
3 files changed, 35 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a0a7128..cb11a3b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,7 @@ fontmap.c fontmap.h \
exec.c exec.h
EXTRA_lcd4linux_SOURCES= \
+acconfig.h \
BeckmannEgle.c \
Crystalfontz.c Crystalfontz.h \
HD44780.c \
diff --git a/Makefile.in b/Makefile.in
index 2294827..65cd610 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -79,7 +79,7 @@ lcd4linux_DEPENDENCIES = @DRIVERS@
lcd4linux_SOURCES = lcd4linux.c debug.c debug.h cfg.c cfg.h lock.c lock.h parser.c parser.h processor.c processor.h system.c system.h isdn.c isdn.h mail.c mail.h seti.c seti.h battery.c battery.h filter.c filter.h udelay.c udelay.h display.c display.h pixmap.c pixmap.h fontmap.c fontmap.h exec.c exec.h
-EXTRA_lcd4linux_SOURCES = BeckmannEgle.c Crystalfontz.c Crystalfontz.h HD44780.c MatrixOrbital.c PalmPilot.c Raster.c SIN.c Skeleton.c XWindow.c Text.c
+EXTRA_lcd4linux_SOURCES = acconfig.h BeckmannEgle.c Crystalfontz.c Crystalfontz.h HD44780.c MatrixOrbital.c PalmPilot.c Raster.c SIN.c Skeleton.c XWindow.c Text.c
EXTRA_DIST = lcd4linux.conf.sample lcd4kde.conf lcd4linux.kdelnk lcd4linux.xpm lcd4linux.lsm CREDITS FAQ NEWS TODO README.Drivers README.MatrixOrbital README.HD44780 README.HD44780.GPO README.Crystalfontz README.X11 README.KDE README.Raster README.Png README.Webinterface README.Text
diff --git a/acconfig.h b/acconfig.h
new file mode 100644
index 0000000..38bf3fb
--- /dev/null
+++ b/acconfig.h
@@ -0,0 +1,33 @@
+/* Define if you want the Beckmann&Egle driver compiled */
+#undef WITH_BECKMANNEGLE
+
+/* Define if you want the Crystalfontz driver compiled */
+#undef WITH_CRYSTALFONTZ
+
+/* Define if you want the HD44780 driver compiled */
+#undef WITH_HD44780
+
+/* Define if you want the Matrix Orbital driver compiled */
+#undef WITH_MATRIXORBITAL
+
+/* Define if you want the PalmPilot driver compiled */
+#undef WITH_PALMPILOT
+
+/* Define if you want the PNG Raster driver compiled */
+#undef WITH_PNG
+
+/* Define if you want the PPM Raster driver compiled */
+#undef WITH_PPM
+
+/* Define if you want the SIN Router driver compiled */
+#undef WITH_SIN
+
+/* Define if you want the Skeleton driver compiled */
+#undef WITH_SKELETON
+
+/* Define if you want the Text driver compiled */
+#undef WITH_TEXT
+
+/* Define if you want the X11 driver compiled */
+#undef WITH_X11
+