aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am1
-rw-r--r--Makefile.in4
-rw-r--r--config.h.in3
-rwxr-xr-xconfigure37
-rw-r--r--configure.in4
-rw-r--r--drivers.m413
-rw-r--r--drv.c9
-rw-r--r--lcd4linux.conf.sample2
8 files changed, 56 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 9124e00..779b40b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,6 +64,7 @@ drv_Curses.c \
drv_Cwlinux.c \
drv_HD44780.c \
drv_Image.c \
+drv_LCDTerm.c \
drv_M50530.c \
drv_MatrixOrbital.c \
drv_MilfordInstruments.c \
diff --git a/Makefile.in b/Makefile.in
index e9b85b6..eda52b5 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -99,7 +99,7 @@ lcd4linux_SOURCES = lcd4linux.c cfg.c cfg.h deb
#liblcd4linux_la_SOURCES =
-EXTRA_lcd4linux_SOURCES = drv_generic_text.c drv_generic_text.h drv_generic_graphic.c drv_generic_graphic.h drv_generic_serial.c drv_generic_serial.h drv_generic_parport.c drv_generic_parport.h drv_BeckmannEgle.c drv_BWCT.c drv_Crystalfontz.c drv_Curses.c drv_Cwlinux.c drv_HD44780.c drv_Image.c drv_M50530.c drv_MatrixOrbital.c drv_MilfordInstruments.c drv_NULL.c drv_RouterBoard.c drv_T6963.c drv_USBLCD.c drv_X11.c font_6x8.h plugin_apm.c plugin_cpuinfo.c plugin_diskstats.c plugin_dvb.c plugin_exec.c plugin_i2c_sensors.c plugin_imon.c plugin_isdn.c plugin_loadavg.c plugin_meminfo.c plugin_mysql.c plugin_netdev.c plugin_pop3.c plugin_ppp.c plugin_proc_stat.c plugin_seti.c plugin_uname.c plugin_uptime.c plugin_wireless.c plugin_xmms.c
+EXTRA_lcd4linux_SOURCES = drv_generic_text.c drv_generic_text.h drv_generic_graphic.c drv_generic_graphic.h drv_generic_serial.c drv_generic_serial.h drv_generic_parport.c drv_generic_parport.h drv_BeckmannEgle.c drv_BWCT.c drv_Crystalfontz.c drv_Curses.c drv_Cwlinux.c drv_HD44780.c drv_Image.c drv_LCDTerm.c drv_M50530.c drv_MatrixOrbital.c drv_MilfordInstruments.c drv_NULL.c drv_RouterBoard.c drv_T6963.c drv_USBLCD.c drv_X11.c font_6x8.h plugin_apm.c plugin_cpuinfo.c plugin_diskstats.c plugin_dvb.c plugin_exec.c plugin_i2c_sensors.c plugin_imon.c plugin_isdn.c plugin_loadavg.c plugin_meminfo.c plugin_mysql.c plugin_netdev.c plugin_pop3.c plugin_ppp.c plugin_proc_stat.c plugin_seti.c plugin_uname.c plugin_uptime.c plugin_wireless.c plugin_xmms.c
EXTRA_DIST = lcd4linux.conf.sample lcd4kde.conf lcd4linux.kdelnk lcd4linux.xpm lcd4linux.lsm curses.m4 AUTHORS CREDITS FAQ NEWS TODO README README.Drivers README.Plugins README.KDE plugin_sample.c
@@ -140,7 +140,7 @@ GZIP_ENV = --best
DEP_FILES = .deps/cfg.P .deps/debug.P .deps/drv.P .deps/drv_BWCT.P \
.deps/drv_BeckmannEgle.P .deps/drv_Crystalfontz.P .deps/drv_Curses.P \
.deps/drv_Cwlinux.P .deps/drv_HD44780.P .deps/drv_Image.P \
-.deps/drv_M50530.P .deps/drv_MatrixOrbital.P \
+.deps/drv_LCDTerm.P .deps/drv_M50530.P .deps/drv_MatrixOrbital.P \
.deps/drv_MilfordInstruments.P .deps/drv_NULL.P .deps/drv_RouterBoard.P \
.deps/drv_T6963.P .deps/drv_USBLCD.P .deps/drv_X11.P \
.deps/drv_generic_graphic.P .deps/drv_generic_parport.P \
diff --git a/config.h.in b/config.h.in
index a81154c..a05eb4b 100644
--- a/config.h.in
+++ b/config.h.in
@@ -332,6 +332,9 @@
/* HD44780 driver */
#undef WITH_HD44780
+/* LCDTerm driver */
+#undef WITH_LCDTERM
+
/* M50530 driver */
#undef WITH_M50530
diff --git a/configure b/configure
index 8d347c2..b503d61 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.59 for LCD4Linux 0.10.0-RC1.
+# Generated by GNU Autoconf 2.59 for LCD4Linux 0.10.0-RC2.
#
# Report bugs to <lcd4linux-users@lists.sourceforge.net>.
#
@@ -269,8 +269,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='LCD4Linux'
PACKAGE_TARNAME='lcd4linux'
-PACKAGE_VERSION='0.10.0-RC1'
-PACKAGE_STRING='LCD4Linux 0.10.0-RC1'
+PACKAGE_VERSION='0.10.0-RC2'
+PACKAGE_STRING='LCD4Linux 0.10.0-RC2'
PACKAGE_BUGREPORT='lcd4linux-users@lists.sourceforge.net'
ac_unique_file="lcd4linux.c"
@@ -780,7 +780,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures LCD4Linux 0.10.0-RC1 to adapt to many kinds of systems.
+\`configure' configures LCD4Linux 0.10.0-RC2 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -846,7 +846,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of LCD4Linux 0.10.0-RC1:";;
+ short | recursive ) echo "Configuration of LCD4Linux 0.10.0-RC2:";;
esac
cat <<\_ACEOF
@@ -868,7 +868,7 @@ Optional Packages:
(try 'all,\!<driver>' if your shell complains...)
possible drivers are:
BeckmannEgle, BWCT, CrystalFontz, Curses, Cwlinux,
- HD44780, M50530, MatrixOrbital, MilfordInstruments,
+ HD44780, LCDTerm, M50530, MatrixOrbital, MilfordInstruments,
NULL, PNG, PPM, RouterBoard, T6963, USBLCD, X11
--with-plugins=<list> choose which plugins to compile.
type --with-plugins=list for a list
@@ -982,7 +982,7 @@ fi
test -n "$ac_init_help" && exit 0
if $ac_init_version; then
cat <<\_ACEOF
-LCD4Linux configure 0.10.0-RC1
+LCD4Linux configure 0.10.0-RC2
generated by GNU Autoconf 2.59
Copyright (C) 2003 Free Software Foundation, Inc.
@@ -996,7 +996,7 @@ cat >&5 <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by LCD4Linux $as_me 0.10.0-RC1, which was
+It was created by LCD4Linux $as_me 0.10.0-RC2, which was
generated by GNU Autoconf 2.59. Invocation command line was
$ $0 $@
@@ -1528,7 +1528,7 @@ fi
PACKAGE=lcd4linux
-VERSION=0.10.0-RC1
+VERSION=0.10.0-RC2
if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
{ { echo "$as_me:$LINENO: error: source directory already configured; run \"make distclean\" there first" >&5
@@ -5407,6 +5407,7 @@ for driver in $drivers; do
CURSES="yes"
CWLINUX="yes"
HD44780="yes"
+ LCDTerm="yes"
M50530="yes"
MATRIXORBITAL="yes"
MILINST="yes"
@@ -5436,6 +5437,9 @@ for driver in $drivers; do
HD44780)
HD44780=$val
;;
+ LCDTerm)
+ LCDTerm=$val
+ ;;
M50530)
M50530=$val
;;
@@ -5559,6 +5563,17 @@ _ACEOF
fi
+if test "$LCDTerm" = "yes"; then
+ TEXT="yes"
+ SERIAL="yes"
+ DRIVERS="$DRIVERS drv_LCDTerm.o"
+
+cat >>confdefs.h <<\_ACEOF
+#define WITH_LCDTERM 1
+_ACEOF
+
+fi
+
if test "$M50530" = "yes"; then
TEXT="yes"
PARPORT="yes"
@@ -10009,7 +10024,7 @@ _ASBOX
} >&5
cat >&5 <<_CSEOF
-This file was extended by LCD4Linux $as_me 0.10.0-RC1, which was
+This file was extended by LCD4Linux $as_me 0.10.0-RC2, which was
generated by GNU Autoconf 2.59. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -10072,7 +10087,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-LCD4Linux config.status 0.10.0-RC1
+LCD4Linux config.status 0.10.0-RC2
configured by $0, generated by GNU Autoconf 2.59,
with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
diff --git a/configure.in b/configure.in
index 3a9f9b1..05f8c06 100644
--- a/configure.in
+++ b/configure.in
@@ -2,9 +2,9 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([LCD4Linux],[0.10.0-RC1],[lcd4linux-users@lists.sourceforge.net])
+AC_INIT([LCD4Linux],[0.10.0-RC2],[lcd4linux-users@lists.sourceforge.net])
AC_CONFIG_SRCDIR([lcd4linux.c])
-AM_INIT_AUTOMAKE([lcd4linux],0.10.0-RC1)
+AM_INIT_AUTOMAKE([lcd4linux],0.10.0-RC2)
AM_CONFIG_HEADER(config.h)
# Checks for programs.
diff --git a/drivers.m4 b/drivers.m4
index 07ab6a6..eecf741 100644
--- a/drivers.m4
+++ b/drivers.m4
@@ -10,7 +10,7 @@ AC_ARG_WITH(
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
[ BeckmannEgle, BWCT, CrystalFontz, Curses, Cwlinux,]
- [ HD44780, M50530, MatrixOrbital, MilfordInstruments,]
+ [ HD44780, LCDTerm, M50530, MatrixOrbital, MilfordInstruments,]
[ NULL, PNG, PPM, RouterBoard, T6963, USBLCD, X11],
drivers=$withval,
drivers=all
@@ -38,6 +38,7 @@ for driver in $drivers; do
CURSES="yes"
CWLINUX="yes"
HD44780="yes"
+ LCDTerm="yes"
M50530="yes"
MATRIXORBITAL="yes"
MILINST="yes"
@@ -67,6 +68,9 @@ for driver in $drivers; do
HD44780)
HD44780=$val
;;
+ LCDTerm)
+ LCDTerm=$val
+ ;;
M50530)
M50530=$val
;;
@@ -161,6 +165,13 @@ if test "$HD44780" = "yes"; then
AC_DEFINE(WITH_HD44780,1,[HD44780 driver])
fi
+if test "$LCDTerm" = "yes"; then
+ TEXT="yes"
+ SERIAL="yes"
+ DRIVERS="$DRIVERS drv_LCDTerm.o"
+ AC_DEFINE(WITH_LCDTERM,1,[LCDTerm driver])
+fi
+
if test "$M50530" = "yes"; then
TEXT="yes"
PARPORT="yes"
diff --git a/drv.c b/drv.c
index c843e51..ea62dcd 100644
--- a/drv.c
+++ b/drv.c
@@ -1,4 +1,4 @@
-/* $Id: drv.c,v 1.23 2004/09/24 21:41:00 reinelt Exp $
+/* $Id: drv.c,v 1.24 2005/01/15 13:10:15 reinelt Exp $
*
* new framework for display drivers
*
@@ -23,6 +23,9 @@
*
*
* $Log: drv.c,v $
+ * Revision 1.24 2005/01/15 13:10:15 reinelt
+ * LCDTerm driver added
+ *
* Revision 1.23 2004/09/24 21:41:00 reinelt
* new driver for the BWCT USB LCD interface board.
*
@@ -177,6 +180,7 @@ extern DRIVER drv_Curses;
extern DRIVER drv_Cwlinux;
extern DRIVER drv_HD44780;
extern DRIVER drv_Image;
+extern DRIVER drv_LCDTerm;
extern DRIVER drv_M50530;
extern DRIVER drv_MatrixOrbital;
extern DRIVER drv_MilfordInstruments;
@@ -214,6 +218,9 @@ DRIVER *Driver[] = {
#if defined (WITH_PNG) || defined(WITH_PPM)
&drv_Image,
#endif
+#ifdef WITH_LCDTERM
+ &drv_LCDTerm,
+#endif
#ifdef WITH_M50530
&drv_M50530,
#endif
diff --git a/lcd4linux.conf.sample b/lcd4linux.conf.sample
index f2d1e5e..ef8e50e 100644
--- a/lcd4linux.conf.sample
+++ b/lcd4linux.conf.sample
@@ -78,6 +78,7 @@ Display HD44780-generic {
Display HD44780-winamp {
Driver 'HD44780'
Model 'generic'
+ UseBusy 1
Port '/dev/parports/0'
Size '20x4'
Wire {
@@ -93,6 +94,7 @@ Display HD44780-winamp {
Display HD44780-kernelconcepts {
Driver 'HD44780'
Model 'HD66712'
+ UseBusy 1
Port '/dev/parports/0'
Size '20x4'
Wire {