aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xconfigure6
-rw-r--r--configure.in1
-rw-r--r--drivers.m46
3 files changed, 11 insertions, 2 deletions
diff --git a/configure b/configure
index e87748c..caea080 100755
--- a/configure
+++ b/configure
@@ -8120,7 +8120,11 @@ echo "$as_me: WARNING: X11 headers or libraries not available: X11 driver disabl
else
GRAPHIC="yes"
DRIVERS="$DRIVERS drv_X11.o"
- DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ if test "x$ac_x_libraries" = "x"; then
+ DRVLIBS="$DRVLIBS -lX11"
+ else
+ DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ fi
CPP_FLAGS="$CPPFLAGS $X_CFLAGS"
cat >>confdefs.h <<\_ACEOF
diff --git a/configure.in b/configure.in
index ca233da..17dd4c5 100644
--- a/configure.in
+++ b/configure.in
@@ -46,6 +46,7 @@ sinclude(curses.m4)
AC_CHECK_CURSES
# Checks for X11
+AC_PATH_X
AC_PATH_XTRA
# double-check for X11
if test "$no_x" != "yes"; then
diff --git a/drivers.m4 b/drivers.m4
index 514230d..3b3b1d2 100644
--- a/drivers.m4
+++ b/drivers.m4
@@ -467,7 +467,11 @@ if test "$X11" = "yes"; then
else
GRAPHIC="yes"
DRIVERS="$DRIVERS drv_X11.o"
- DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ if test "x$ac_x_libraries" = "x"; then
+ DRVLIBS="$DRVLIBS -lX11"
+ else
+ DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ fi
CPP_FLAGS="$CPPFLAGS $X_CFLAGS"
AC_DEFINE(WITH_X11, 1, [X11 driver])
fi