aboutsummaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
authorreinelt <>2004-01-30 20:57:56 +0000
committerreinelt <>2004-01-30 20:57:56 +0000
commitd17399872e191a60fa783fb115787d1bdd4cca5a (patch)
tree6577cd2c6172763a0223ed7bb933657b1c5b5436 /configure
parent1ffb8be56b4017149d8c108aee2eeaf881a88d3e (diff)
downloadlcd4linux-d17399872e191a60fa783fb115787d1bdd4cca5a.tar.gz
[lcd4linux @ 2004-01-30 20:57:55 by reinelt]
HD44780 patch from Martin Hejl dmalloc integrated
Diffstat (limited to '')
-rwxr-xr-xconfigure87
-rw-r--r--configure.in3
2 files changed, 61 insertions, 29 deletions
diff --git a/configure b/configure
index 28139d1..969c17e 100755
--- a/configure
+++ b/configure
@@ -1047,6 +1047,8 @@ Optional Packages:
both]
--with-tags[=TAGS]
include additional configurations [automatic]
+ --with-dmalloc use dmalloc, as in
+ ftp://ftp.letters.com/src/dmalloc/dmalloc.tar.gz
--with-sco Use this to turn on SCO-specific code
--with-sunos-curses Used to force SunOS 4.x curses
--with-osf1-curses Used to force OSF/1 curses
@@ -4044,7 +4046,7 @@ ia64-*-hpux*)
;;
*-*-irix6*)
# Find out which ABI we are using.
- echo '#line 4047 "configure"' > conftest.$ac_ext
+ echo '#line 4049 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -4914,7 +4916,7 @@ fi
# Provide some information about the compiler.
-echo "$as_me:4917:" \
+echo "$as_me:4919:" \
"checking for Fortran 77 compiler version" >&5
ac_compiler=`set X $ac_compile; echo $2`
{ (eval echo "$as_me:$LINENO: \"$ac_compiler --version </dev/null >&5\"") >&5
@@ -5946,11 +5948,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:5949: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:5951: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:5953: \$? = $ac_status" >&5
+ echo "$as_me:5955: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -6179,11 +6181,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:6182: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:6184: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:6186: \$? = $ac_status" >&5
+ echo "$as_me:6188: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -6246,11 +6248,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:6249: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:6251: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:6253: \$? = $ac_status" >&5
+ echo "$as_me:6255: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -8421,7 +8423,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 8424 "configure"
+#line 8426 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -8519,7 +8521,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 8522 "configure"
+#line 8524 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -10696,11 +10698,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:10699: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:10701: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:10703: \$? = $ac_status" >&5
+ echo "$as_me:10705: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -10763,11 +10765,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:10766: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:10768: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:10770: \$? = $ac_status" >&5
+ echo "$as_me:10772: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -12117,7 +12119,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 12120 "configure"
+#line 12122 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -12215,7 +12217,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 12218 "configure"
+#line 12220 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -13042,11 +13044,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:13045: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:13047: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:13049: \$? = $ac_status" >&5
+ echo "$as_me:13051: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -13109,11 +13111,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:13112: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:13114: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:13116: \$? = $ac_status" >&5
+ echo "$as_me:13118: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -15141,11 +15143,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:15144: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:15146: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:15148: \$? = $ac_status" >&5
+ echo "$as_me:15150: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -15374,11 +15376,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:15377: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:15379: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:15381: \$? = $ac_status" >&5
+ echo "$as_me:15383: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -15441,11 +15443,11 @@ else
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:15444: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:15446: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:15448: \$? = $ac_status" >&5
+ echo "$as_me:15450: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -17616,7 +17618,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 17619 "configure"
+#line 17621 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -17714,7 +17716,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 17717 "configure"
+#line 17719 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -18729,6 +18731,33 @@ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+# dmalloc
+echo "$as_me:$LINENO: checking if malloc debugging is wanted" >&5
+echo $ECHO_N "checking if malloc debugging is wanted... $ECHO_C" >&6
+
+# Check whether --with-dmalloc or --without-dmalloc was given.
+if test "${with_dmalloc+set}" = set; then
+ withval="$with_dmalloc"
+ if test "$withval" = yes; then
+ echo "$as_me:$LINENO: result: yes" >&5
+echo "${ECHO_T}yes" >&6
+
+cat >>confdefs.h <<\_ACEOF
+#define WITH_DMALLOC 1
+_ACEOF
+
+ LIBS="$LIBS -ldmalloc"
+ LDFLAGS="$LDFLAGS -g"
+else
+ echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6
+fi
+else
+ echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6
+fi;
+
+
# Checks for libraries.
echo "$as_me:$LINENO: checking for log in -lm" >&5
@@ -19253,7 +19282,7 @@ echo "${ECHO_T}Please note that some screen refreshs may fail" >&6
echo $ECHO_N "checking for ncurses version... $ECHO_C" >&6
ncurses_version=unknown
cat > conftest.$ac_ext <<EOF
-#line 19256 "configure"
+#line 19285 "configure"
#include "confdefs.h"
#ifdef RENAMED_NCURSES
#include <curses.h>
diff --git a/configure.in b/configure.in
index 652386d..821f245 100644
--- a/configure.in
+++ b/configure.in
@@ -19,6 +19,9 @@ AC_PROG_MAKE_SET
#AC_PROG_RANLIB
AC_PROG_LIBTOOL
+# dmalloc
+AM_WITH_DMALLOC
+
# Checks for libraries.
AC_CHECK_LIB(m, log)