aboutsummaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
authorreinelt <>2005-01-15 13:10:15 +0000
committerreinelt <>2005-01-15 13:10:15 +0000
commit8bfcda7f0600e1a1502b08fb2b0815423ec6b086 (patch)
tree507bb6d30d18f3a03b1a924d7584a1f426acab30 /configure
parentbc3a6a5399476e4076c8ae8b054808d5d5a3617d (diff)
downloadlcd4linux-8bfcda7f0600e1a1502b08fb2b0815423ec6b086.tar.gz
[lcd4linux @ 2005-01-15 13:10:13 by reinelt]
LCDTerm driver added
Diffstat (limited to '')
-rwxr-xr-xconfigure37
-rw-r--r--configure.in4
2 files changed, 28 insertions, 13 deletions
diff --git a/configure b/configure
index 8d347c2..b503d61 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.59 for LCD4Linux 0.10.0-RC1.
+# Generated by GNU Autoconf 2.59 for LCD4Linux 0.10.0-RC2.
#
# Report bugs to <lcd4linux-users@lists.sourceforge.net>.
#
@@ -269,8 +269,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='LCD4Linux'
PACKAGE_TARNAME='lcd4linux'
-PACKAGE_VERSION='0.10.0-RC1'
-PACKAGE_STRING='LCD4Linux 0.10.0-RC1'
+PACKAGE_VERSION='0.10.0-RC2'
+PACKAGE_STRING='LCD4Linux 0.10.0-RC2'
PACKAGE_BUGREPORT='lcd4linux-users@lists.sourceforge.net'
ac_unique_file="lcd4linux.c"
@@ -780,7 +780,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures LCD4Linux 0.10.0-RC1 to adapt to many kinds of systems.
+\`configure' configures LCD4Linux 0.10.0-RC2 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -846,7 +846,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of LCD4Linux 0.10.0-RC1:";;
+ short | recursive ) echo "Configuration of LCD4Linux 0.10.0-RC2:";;
esac
cat <<\_ACEOF
@@ -868,7 +868,7 @@ Optional Packages:
(try 'all,\!<driver>' if your shell complains...)
possible drivers are:
BeckmannEgle, BWCT, CrystalFontz, Curses, Cwlinux,
- HD44780, M50530, MatrixOrbital, MilfordInstruments,
+ HD44780, LCDTerm, M50530, MatrixOrbital, MilfordInstruments,
NULL, PNG, PPM, RouterBoard, T6963, USBLCD, X11
--with-plugins=<list> choose which plugins to compile.
type --with-plugins=list for a list
@@ -982,7 +982,7 @@ fi
test -n "$ac_init_help" && exit 0
if $ac_init_version; then
cat <<\_ACEOF
-LCD4Linux configure 0.10.0-RC1
+LCD4Linux configure 0.10.0-RC2
generated by GNU Autoconf 2.59
Copyright (C) 2003 Free Software Foundation, Inc.
@@ -996,7 +996,7 @@ cat >&5 <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by LCD4Linux $as_me 0.10.0-RC1, which was
+It was created by LCD4Linux $as_me 0.10.0-RC2, which was
generated by GNU Autoconf 2.59. Invocation command line was
$ $0 $@
@@ -1528,7 +1528,7 @@ fi
PACKAGE=lcd4linux
-VERSION=0.10.0-RC1
+VERSION=0.10.0-RC2
if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
{ { echo "$as_me:$LINENO: error: source directory already configured; run \"make distclean\" there first" >&5
@@ -5407,6 +5407,7 @@ for driver in $drivers; do
CURSES="yes"
CWLINUX="yes"
HD44780="yes"
+ LCDTerm="yes"
M50530="yes"
MATRIXORBITAL="yes"
MILINST="yes"
@@ -5436,6 +5437,9 @@ for driver in $drivers; do
HD44780)
HD44780=$val
;;
+ LCDTerm)
+ LCDTerm=$val
+ ;;
M50530)
M50530=$val
;;
@@ -5559,6 +5563,17 @@ _ACEOF
fi
+if test "$LCDTerm" = "yes"; then
+ TEXT="yes"
+ SERIAL="yes"
+ DRIVERS="$DRIVERS drv_LCDTerm.o"
+
+cat >>confdefs.h <<\_ACEOF
+#define WITH_LCDTERM 1
+_ACEOF
+
+fi
+
if test "$M50530" = "yes"; then
TEXT="yes"
PARPORT="yes"
@@ -10009,7 +10024,7 @@ _ASBOX
} >&5
cat >&5 <<_CSEOF
-This file was extended by LCD4Linux $as_me 0.10.0-RC1, which was
+This file was extended by LCD4Linux $as_me 0.10.0-RC2, which was
generated by GNU Autoconf 2.59. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -10072,7 +10087,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-LCD4Linux config.status 0.10.0-RC1
+LCD4Linux config.status 0.10.0-RC2
configured by $0, generated by GNU Autoconf 2.59,
with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
diff --git a/configure.in b/configure.in
index 3a9f9b1..05f8c06 100644
--- a/configure.in
+++ b/configure.in
@@ -2,9 +2,9 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([LCD4Linux],[0.10.0-RC1],[lcd4linux-users@lists.sourceforge.net])
+AC_INIT([LCD4Linux],[0.10.0-RC2],[lcd4linux-users@lists.sourceforge.net])
AC_CONFIG_SRCDIR([lcd4linux.c])
-AM_INIT_AUTOMAKE([lcd4linux],0.10.0-RC1)
+AM_INIT_AUTOMAKE([lcd4linux],0.10.0-RC2)
AM_CONFIG_HEADER(config.h)
# Checks for programs.