aboutsummaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2006-08-26 10:52:44 +0200
committerReinhard Tartler <siretart@tauware.de>2006-08-26 10:52:44 +0200
commit7ea355421e25c91dd46235f49246c6a21bdeae2b (patch)
tree6796ca0be12a822b6e20a320544b3fc2b4d54fa1 /configure
parent5ae5da7c598d6a4088f6392df00c8e6e28b86a54 (diff)
downloadlcd4linux-7ea355421e25c91dd46235f49246c6a21bdeae2b.tar.gz
fix FTBFS because of X11
Diffstat (limited to '')
-rwxr-xr-xconfigure6
-rw-r--r--configure.in1
2 files changed, 6 insertions, 1 deletions
diff --git a/configure b/configure
index e87748c..caea080 100755
--- a/configure
+++ b/configure
@@ -8120,7 +8120,11 @@ echo "$as_me: WARNING: X11 headers or libraries not available: X11 driver disabl
else
GRAPHIC="yes"
DRIVERS="$DRIVERS drv_X11.o"
- DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ if test "x$ac_x_libraries" = "x"; then
+ DRVLIBS="$DRVLIBS -lX11"
+ else
+ DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ fi
CPP_FLAGS="$CPPFLAGS $X_CFLAGS"
cat >>confdefs.h <<\_ACEOF
diff --git a/configure.in b/configure.in
index ca233da..17dd4c5 100644
--- a/configure.in
+++ b/configure.in
@@ -46,6 +46,7 @@ sinclude(curses.m4)
AC_CHECK_CURSES
# Checks for X11
+AC_PATH_X
AC_PATH_XTRA
# double-check for X11
if test "$no_x" != "yes"; then