aboutsummaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
authorreinelt <>2005-06-03 17:05:05 +0000
committerreinelt <>2005-06-03 17:05:05 +0000
commit7c66aa9264793922a114ec0b7f9156b9a9e46846 (patch)
tree6204c20e839fe14fc6b477efb0eef88e7e167a4e /configure
parent2f604e2253fd3c87c7f177da9be551aef44db559 (diff)
downloadlcd4linux-7c66aa9264793922a114ec0b7f9156b9a9e46846.tar.gz
[lcd4linux @ 2005-06-03 17:04:52 by reinelt]
hopefully solved the AM_PYTHON_PATH issue finally
Diffstat (limited to '')
-rwxr-xr-xconfigure200
-rw-r--r--configure.in2
2 files changed, 3 insertions, 199 deletions
diff --git a/configure b/configure
index 49b21f8..8ec29d5 100755
--- a/configure
+++ b/configure
@@ -311,7 +311,7 @@ ac_includes_default="\
# include <unistd.h>
#endif"
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO SET_MAKE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT CPP LN_S CURSES_LIBS CURSES_INCLUDEDIR EGREP X_CFLAGS X_PRE_LIBS X_LIBS X_EXTRA_LIBS PYTHON PYTHON_VERSION PYTHON_PREFIX PYTHON_EXEC_PREFIX PYTHON_PLATFORM pythondir pkgpythondir pyexecdir pkgpyexecdir PYTHON_CPPFLAGS PYTHON_LDFLAGS PYTHON_SITE_PKG PYTHON_EXTRA_LIBS DRIVERS DRVLIBS PLUGINS PLUGINLIBS LIBOBJS POW_LIB LTLIBOBJS'
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO SET_MAKE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT CPP LN_S CURSES_LIBS CURSES_INCLUDEDIR EGREP X_CFLAGS X_PRE_LIBS X_LIBS X_EXTRA_LIBS DRIVERS DRVLIBS PLUGINS PLUGINLIBS LIBOBJS POW_LIB LTLIBOBJS'
ac_subst_files=''
# Initialize some variables set by options.
@@ -5665,8 +5665,6 @@ if test "$with_python" = "yes"; then
# doesn't meet the requirement. MINIMUM-VERSION should consist of
# numbers and dots only.
-# M.Reinelt 2005/06/03: Changed name from AM_... to MY_PYTH_PYTHON
-
@@ -5686,188 +5684,7 @@ if test "$with_python" = "yes"; then
-
-
-
- # Find any Python interpreter.
- for ac_prog in python python2 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
-do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
-set dummy $ac_prog; ac_word=$2
-echo "$as_me:$LINENO: checking for $ac_word" >&5
-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
-if test "${ac_cv_path_PYTHON+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- case $PYTHON in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_PYTHON="$PYTHON" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_path_PYTHON="$as_dir/$ac_word$ac_exec_ext"
- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
-done
-
- ;;
-esac
-fi
-PYTHON=$ac_cv_path_PYTHON
-
-if test -n "$PYTHON"; then
- echo "$as_me:$LINENO: result: $PYTHON" >&5
-echo "${ECHO_T}$PYTHON" >&6
-else
- echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6
-fi
-
- test -n "$PYTHON" && break
-done
-
- am_display_PYTHON=python
-
-
-
- echo "$as_me:$LINENO: checking for $am_display_PYTHON version" >&5
-echo $ECHO_N "checking for $am_display_PYTHON version... $ECHO_C" >&6
-if test "${am_cv_python_version+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- am_cv_python_version=`$PYTHON -c "import sys; print sys.version[:3]"`
-fi
-echo "$as_me:$LINENO: result: $am_cv_python_version" >&5
-echo "${ECHO_T}$am_cv_python_version" >&6
- PYTHON_VERSION=$am_cv_python_version
-
-
-
- PYTHON_PREFIX='${prefix}'
-
- PYTHON_EXEC_PREFIX='${exec_prefix}'
-
-
-
- echo "$as_me:$LINENO: checking for $am_display_PYTHON platform" >&5
-echo $ECHO_N "checking for $am_display_PYTHON platform... $ECHO_C" >&6
-if test "${am_cv_python_platform+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- am_cv_python_platform=`$PYTHON -c "import sys; print sys.platform"`
-fi
-echo "$as_me:$LINENO: result: $am_cv_python_platform" >&5
-echo "${ECHO_T}$am_cv_python_platform" >&6
- PYTHON_PLATFORM=$am_cv_python_platform
-
-
-
-
- echo "$as_me:$LINENO: checking for $am_display_PYTHON script directory" >&5
-echo $ECHO_N "checking for $am_display_PYTHON script directory... $ECHO_C" >&6
-if test "${am_cv_python_pythondir+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- am_cv_python_pythondir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(0,0,prefix='$PYTHON_PREFIX')" 2>/dev/null ||
- echo "$PYTHON_PREFIX/lib/python$PYTHON_VERSION/site-packages"`
-fi
-echo "$as_me:$LINENO: result: $am_cv_python_pythondir" >&5
-echo "${ECHO_T}$am_cv_python_pythondir" >&6
- pythondir=$am_cv_python_pythondir
-
-
-
- pkgpythondir=\${pythondir}/$PACKAGE
-
-
- echo "$as_me:$LINENO: checking for $am_display_PYTHON extension module directory" >&5
-echo $ECHO_N "checking for $am_display_PYTHON extension module directory... $ECHO_C" >&6
-if test "${am_cv_python_pyexecdir+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- am_cv_python_pyexecdir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(1,0,prefix='$PYTHON_EXEC_PREFIX')" 2>/dev/null ||
- echo "${PYTHON_EXEC_PREFIX}/lib/python${PYTHON_VERSION}/site-packages"`
-fi
-echo "$as_me:$LINENO: result: $am_cv_python_pyexecdir" >&5
-echo "${ECHO_T}$am_cv_python_pyexecdir" >&6
- pyexecdir=$am_cv_python_pyexecdir
-
-
-
- pkgpyexecdir=\${pyexecdir}/$PACKAGE
-
-
-
- #
- # should allow for checking of python version here...
- #
-
-
- # Check for Python include path
- echo "$as_me:$LINENO: checking for Python include path" >&5
-echo $ECHO_N "checking for Python include path... $ECHO_C" >&6
- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
- for i in "$python_path/include/python$PYTHON_VERSION/" "$python_path/include/python/" "$python_path/" ; do
- python_path=`find $i -type f -name Python.h -print | sed "1q"`
- if test -n "$python_path" ; then
- break
- fi
- done
- python_path=`echo $python_path | sed "s,/Python.h$,,"`
- echo "$as_me:$LINENO: result: $python_path" >&5
-echo "${ECHO_T}$python_path" >&6
- if test -z "$python_path" ; then
- { { echo "$as_me:$LINENO: error: cannot find Python include path" >&5
-echo "$as_me: error: cannot find Python include path" >&2;}
- { (exit 1); exit 1; }; }
- fi
- PYTHON_CPPFLAGS=-I$python_path
-
-
- # Check for Python library path
- echo "$as_me:$LINENO: checking for Python library path" >&5
-echo $ECHO_N "checking for Python library path... $ECHO_C" >&6
- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
- if test -n "$python_path" ; then
- break
- fi
- done
- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
- echo "$as_me:$LINENO: result: $python_path" >&5
-echo "${ECHO_T}$python_path" >&6
- if test -z "$python_path" ; then
- { { echo "$as_me:$LINENO: error: cannot find Python library path" >&5
-echo "$as_me: error: cannot find Python library path" >&2;}
- { (exit 1); exit 1; }; }
- fi
- PYTHON_LDFLAGS="-L$python_path -lpython$PYTHON_VERSION"
-
- #
- python_site=`echo $python_path | sed "s/config/site-packages/"`
- PYTHON_SITE_PKG=$python_site
-
- #
- # libraries which must be linked in when embedding
- #
- echo "$as_me:$LINENO: checking python extra libraries" >&5
-echo $ECHO_N "checking python extra libraries... $ECHO_C" >&6
- PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
- conf = distutils.sysconfig.get_config_var; \
- print conf('LOCALMODLIBS')+' '+conf('LIBS')"
- echo "$as_me:$LINENO: result: $PYTHON_EXTRA_LIBS" >&5
-echo "${ECHO_T}$PYTHON_EXTRA_LIBS" >&6`
-
-
+ PYTHON__DEVEL
fi
# drivers
@@ -11020,19 +10837,6 @@ s,@X_CFLAGS@,$X_CFLAGS,;t t
s,@X_PRE_LIBS@,$X_PRE_LIBS,;t t
s,@X_LIBS@,$X_LIBS,;t t
s,@X_EXTRA_LIBS@,$X_EXTRA_LIBS,;t t
-s,@PYTHON@,$PYTHON,;t t
-s,@PYTHON_VERSION@,$PYTHON_VERSION,;t t
-s,@PYTHON_PREFIX@,$PYTHON_PREFIX,;t t
-s,@PYTHON_EXEC_PREFIX@,$PYTHON_EXEC_PREFIX,;t t
-s,@PYTHON_PLATFORM@,$PYTHON_PLATFORM,;t t
-s,@pythondir@,$pythondir,;t t
-s,@pkgpythondir@,$pkgpythondir,;t t
-s,@pyexecdir@,$pyexecdir,;t t
-s,@pkgpyexecdir@,$pkgpyexecdir,;t t
-s,@PYTHON_CPPFLAGS@,$PYTHON_CPPFLAGS,;t t
-s,@PYTHON_LDFLAGS@,$PYTHON_LDFLAGS,;t t
-s,@PYTHON_SITE_PKG@,$PYTHON_SITE_PKG,;t t
-s,@PYTHON_EXTRA_LIBS@,$PYTHON_EXTRA_LIBS,;t t
s,@DRIVERS@,$DRIVERS,;t t
s,@DRVLIBS@,$DRVLIBS,;t t
s,@PLUGINS@,$PLUGINS,;t t
diff --git a/configure.in b/configure.in
index f013ac8..8af1ba2 100644
--- a/configure.in
+++ b/configure.in
@@ -64,7 +64,7 @@ AC_ARG_WITH(python,
[AC_MSG_RESULT($withval)], [AC_MSG_RESULT(no)])
if test "$with_python" = "yes"; then
sinclude(python.m4)
- MY_PYTHON_DEVEL
+ PYTHON__DEVEL
fi
# drivers