aboutsummaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
authorreinelt <>2004-02-15 21:43:43 +0000
committerreinelt <>2004-02-15 21:43:43 +0000
commit55e2a61f5ebc3dbdc5336b98330d57bf6256a175 (patch)
tree6e2799b6464df37df69358ed5a482546c4135796 /configure
parentb331ef79fcbdbab27308a34f438b5646c37b9992 (diff)
downloadlcd4linux-55e2a61f5ebc3dbdc5336b98330d57bf6256a175.tar.gz
[lcd4linux @ 2004-02-15 21:43:43 by reinelt]
T6963 driver nearly finished framework for graphic displays done i2c_sensors patch from Xavier some more old generation files removed
Diffstat (limited to '')
-rwxr-xr-xconfigure22
-rw-r--r--configure.in22
2 files changed, 26 insertions, 18 deletions
diff --git a/configure b/configure
index 03f32b9..6925598 100755
--- a/configure
+++ b/configure
@@ -20935,7 +20935,7 @@ echo "${ECHO_T}done" >&6
PARPORT="no"
SERIAL="no"
TEXT="no"
-RASTER="no"
+GRAPHIC="no"
if test "$BECKMANNEGLE" = "yes"; then
# DRIVERS="$DRIVERS BeckmannEgle.lo"
@@ -20984,6 +20984,7 @@ _ACEOF
fi
if test "$M50530" = "yes"; then
+ TEXT="yes"
PARPORT="yes"
# DRIVERS="$DRIVERS drv_M50530.lo"
DRIVERS="$DRIVERS drv_M50530.o"
@@ -20995,9 +20996,10 @@ _ACEOF
fi
if test "$T6963" = "yes"; then
+ GRAPHIC="yes"
PARPORT="yes"
-# DRIVERS="$DRIVERS T6963.lo"
-# DRIVERS="$DRIVERS T6963.o"
+# DRIVERS="$DRIVERS drv_T6963.lo"
+ DRIVERS="$DRIVERS drv_T6963.o"
cat >>confdefs.h <<\_ACEOF
#define WITH_T6963 1
@@ -21006,6 +21008,8 @@ _ACEOF
fi
if test "$USBLCD" = "yes"; then
+ TEXT="yes"
+ SERIAL="yes"
# DRIVERS="$DRIVERS drv_USBLCD.lo"
DRIVERS="$DRIVERS drv_USBLCD.o"
@@ -21048,7 +21052,7 @@ fi
if test "$PNG" = "yes"; then
if test "$has_gd" = "true"; then
- RASTER="yes"
+ GRAPHIC="yes"
cat >>confdefs.h <<\_ACEOF
#define WITH_PNG 1
@@ -21063,7 +21067,7 @@ fi
if test "$PPM" = "yes"; then
if test "$has_gd" = "true"; then
- RASTER="yes"
+ GRAPHIC="yes"
cat >>confdefs.h <<\_ACEOF
#define WITH_PPM 1
@@ -21121,11 +21125,11 @@ if test "$TEXT" = "yes"; then
DRIVERS="$DRIVERS drv_generic_text.o"
fi
-# Raster.lo depends on PPM or PNG
-if test "$RASTER" = "yes"; then
+# generic graphic driver
+if test "$GRAPHIC" = "yes"; then
:
-# DRIVERS="$DRIVERS Raster.lo"
-# DRIVERS="$DRIVERS Raster.o"
+# DRIVERS="$DRIVERS
+ DRIVERS="$DRIVERS drv_generic_graphic.o"
fi
# generic parport driver
diff --git a/configure.in b/configure.in
index 731a3d5..cd157bc 100644
--- a/configure.in
+++ b/configure.in
@@ -142,7 +142,7 @@ AC_MSG_RESULT([done])
PARPORT="no"
SERIAL="no"
TEXT="no"
-RASTER="no"
+GRAPHIC="no"
if test "$BECKMANNEGLE" = "yes"; then
# DRIVERS="$DRIVERS BeckmannEgle.lo"
@@ -175,6 +175,7 @@ if test "$HD44780" = "yes"; then
fi
if test "$M50530" = "yes"; then
+ TEXT="yes"
PARPORT="yes"
# DRIVERS="$DRIVERS drv_M50530.lo"
DRIVERS="$DRIVERS drv_M50530.o"
@@ -182,13 +183,16 @@ if test "$M50530" = "yes"; then
fi
if test "$T6963" = "yes"; then
+ GRAPHIC="yes"
PARPORT="yes"
-# DRIVERS="$DRIVERS T6963.lo"
-# DRIVERS="$DRIVERS T6963.o"
+# DRIVERS="$DRIVERS drv_T6963.lo"
+ DRIVERS="$DRIVERS drv_T6963.o"
AC_DEFINE(WITH_T6963,1,[T6963 driver])
fi
if test "$USBLCD" = "yes"; then
+ TEXT="yes"
+ SERIAL="yes"
# DRIVERS="$DRIVERS drv_USBLCD.lo"
DRIVERS="$DRIVERS drv_USBLCD.o"
AC_DEFINE(WITH_USBLCD,1,[USBLCD driver])
@@ -215,7 +219,7 @@ fi
if test "$PNG" = "yes"; then
if test "$has_gd" = "true"; then
- RASTER="yes"
+ GRAPHIC="yes"
AC_DEFINE(WITH_PNG,1,[ driver])
DRVLIBS="$DRVLIBS -lgd"
else
@@ -225,7 +229,7 @@ fi
if test "$PPM" = "yes"; then
if test "$has_gd" = "true"; then
- RASTER="yes"
+ GRAPHIC="yes"
AC_DEFINE(WITH_PPM,1,[ driver])
else
AC_MSG_WARN(gd.h not found: PNG driver disabled)
@@ -265,11 +269,11 @@ if test "$TEXT" = "yes"; then
DRIVERS="$DRIVERS drv_generic_text.o"
fi
-# Raster.lo depends on PPM or PNG
-if test "$RASTER" = "yes"; then
+# generic graphic driver
+if test "$GRAPHIC" = "yes"; then
:
-# DRIVERS="$DRIVERS Raster.lo"
-# DRIVERS="$DRIVERS Raster.o"
+# DRIVERS="$DRIVERS
+ DRIVERS="$DRIVERS drv_generic_graphic.o"
fi
# generic parport driver