aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <>2004-02-17 05:37:20 +0000
committerreinelt <>2004-02-17 05:37:20 +0000
commited997d43ead02dc726a8f5ce3c9e1914ba7eac9b (patch)
treecdd3a0c9cc5815ac52248f6368b15bb2cebe70db /configure.in
parent53aa30c03a500767a3507d6fecbb7684515c38e6 (diff)
downloadlcd4linux-ed997d43ead02dc726a8f5ce3c9e1914ba7eac9b.tar.gz
[lcd4linux @ 2004-02-17 05:37:20 by reinelt]
Namespace clash between Curses driver and general text driver resolved (thanks to Martin Hejl)
Diffstat (limited to '')
-rw-r--r--configure.in44
1 files changed, 19 insertions, 25 deletions
diff --git a/configure.in b/configure.in
index cd157bc..8ea41cf 100644
--- a/configure.in
+++ b/configure.in
@@ -45,9 +45,9 @@ AC_ARG_WITH(
[ drivers may be excluded with 'all,!<driver>',]
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
- [ BeckmannEgle, CrystalFontz, Cwlinux, HD44780,]
- [ M50530, T6963, USBLCD, MatrixOrbital,]
- [ MilfordInstruments, PalmPilot, PNG, PPM, X11, Text],
+ [ BeckmannEgle, CrystalFontz, Curses, Cwlinux,]
+ [ HD44780, M50530, T6963, USBLCD, MatrixOrbital,]
+ [ MilfordInstruments, PalmPilot, PNG, PPM, X11],
drivers=$withval,
drivers=all
)
@@ -70,6 +70,7 @@ for driver in $drivers; do
all)
BECKMANNEGLE="yes"
CRYSTALFONTZ="yes"
+ CURSES="yes"
CWLINUX="yes"
HD44780="yes"
M50530="yes"
@@ -80,7 +81,6 @@ for driver in $drivers; do
PALMPILOT="yes"
PNG="yes"
PPM="yes"
- TEXT="yes"
X11="yes"
;;
BeckmannEgle)
@@ -89,6 +89,9 @@ for driver in $drivers; do
CrystalFontz)
CRYSTALFONTZ=$val
;;
+ Curses)
+ CURSES=$val
+ ;;
Cwlinux)
CWLINUX=$val
;;
@@ -119,15 +122,6 @@ for driver in $drivers; do
PPM)
PPM=$val
;;
- SIN)
- SIN=$val
- ;;
- Skeleton)
- SKELETON=$val
- ;;
- Text)
- TEXT=$val
- ;;
X11)
X11=$val
;;
@@ -158,6 +152,18 @@ if test "$CRYSTALFONTZ" = "yes"; then
AC_DEFINE(WITH_CRYSTALFONTZ,1,[Crystalfontz driver])
fi
+if test "$CURSES" = "yes"; then
+ if test "$has_curses" = true; then
+# DRIVERS="$DRIVERS Text.lo"
+# DRIVERS="$DRIVERS Text.o"
+ DRVLIBS="$DRVLIBS $CURSES_LIBS"
+ CPPFLAGS="$CPPFLAGS $CURSES_INCLUDES"
+ AC_DEFINE(WITH_TEXT,1,[Curses driver])
+ else
+ AC_MSG_WARN(curses not found: Curses driver disabled)
+ fi
+fi
+
if test "$CWLINUX" = "yes"; then
TEXT="yes"
SERIAL="yes"
@@ -236,18 +242,6 @@ if test "$PPM" = "yes"; then
fi
fi
-if test "$TEXT" = "yes"; then
- if test "$has_curses" = true; then
-# DRIVERS="$DRIVERS Text.lo"
-# DRIVERS="$DRIVERS Text.o"
- DRVLIBS="$DRVLIBS $CURSES_LIBS"
- CPPFLAGS="$CPPFLAGS $CURSES_INCLUDES"
- AC_DEFINE(WITH_TEXT,1,[Curses driver])
- else
- AC_MSG_WARN(curses not found: Text driver disabled)
- fi
-fi
-
if test "$X11" = "yes"; then
if test "$no_x" = "yes"; then
AC_MSG_ERROR(X11 headers or libraries not available: X11 driver disabled)