aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorreinelt <>2006-01-23 06:17:18 +0000
committerreinelt <>2006-01-23 06:17:18 +0000
commitbbc3ae1aa6375621c9a9f7e5ea5bb8a3d43d8df3 (patch)
tree013c1d2a26d499b1ea3417ce9ff754af16014804 /Makefile.am
parentd827ea04a3e9d183c7e8ef78761a288f4e1b8859 (diff)
downloadlcd4linux-bbc3ae1aa6375621c9a9f7e5ea5bb8a3d43d8df3.tar.gz
[lcd4linux @ 2006-01-23 06:17:18 by reinelt]
timer widget added
Diffstat (limited to '')
-rw-r--r--Makefile.am215
1 files changed, 108 insertions, 107 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d9b8dc..a5eeee7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,118 +13,119 @@ lcd4linux_LDFLAGS =
lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@
-lcd4linux_SOURCES = \
-lcd4linux.c \
-cfg.c cfg.h \
-debug.c debug.h \
-drv.c drv.h \
-evaluator.c evaluator.h \
-hash.c hash.h \
-layout.c layout.h \
-pid.c pid.h \
-timer.c timer.h \
-thread.c thread.h \
-udelay.c udelay.h \
-qprintf.c qprintf.h \
- \
-widget.c widget.h \
-widget_text.c widget_text.h \
-widget_bar.c widget_bar.h \
-widget_icon.c widget_icon.h \
+lcd4linux_SOURCES = \
+lcd4linux.c \
+cfg.c cfg.h \
+debug.c debug.h \
+drv.c drv.h \
+evaluator.c evaluator.h \
+hash.c hash.h \
+layout.c layout.h \
+pid.c pid.h \
+timer.c timer.h \
+thread.c thread.h \
+udelay.c udelay.h \
+qprintf.c qprintf.h \
+ \
+widget.c widget.h \
+widget_text.c widget_text.h \
+widget_bar.c widget_bar.h \
+widget_icon.c widget_icon.h \
widget_image.c widget_image.h \
-widget_gpo.c widget_gpo.h \
- \
-plugin.c plugin.h \
-plugin_cfg.c \
-plugin_math.c \
-plugin_string.c \
-plugin_test.c \
+widget_timer.c widget_timer.h \
+widget_gpo.c widget_gpo.h \
+ \
+plugin.c plugin.h \
+plugin_cfg.c \
+plugin_math.c \
+plugin_string.c \
+plugin_test.c \
plugin_time.c
-EXTRA_lcd4linux_SOURCES= \
-drv_generic_text.c \
-drv_generic_text.h \
-drv_generic_graphic.c \
-drv_generic_graphic.h \
-drv_generic_gpio.c \
-drv_generic_gpio.h \
-drv_generic_serial.c \
-drv_generic_serial.h \
-drv_generic_parport.c \
-drv_generic_parport.h \
-drv_generic_i2c.c \
-drv_generic_i2c.h \
-drv_BeckmannEgle.c \
-drv_BWCT.c \
-drv_Crystalfontz.c \
-drv_Curses.c \
-drv_Cwlinux.c \
-drv_G15.c \
-drv_HD44780.c \
-drv_Image.c \
-drv_LCDLinux.c \
-drv_LCDTerm.c \
-drv_LPH7508.c \
-drv_LUIse.c \
-drv_M50530.c \
-drv_MatrixOrbital.c \
-drv_MilfordInstruments.c \
-drv_Noritake.c \
-drv_NULL.c \
-drv_RouterBoard.c \
-drv_Sample.c \
-drv_serdisplib.c \
-drv_SimpleLCD.c \
-drv_T6963.c \
-drv_Trefon.c \
-drv_USBLCD.c \
-drv_WincorNixdorf.c \
-drv_X11.c \
- \
-font_6x8.h \
- \
-lcd4linux_i2c.h \
- \
-plugin_apm.c \
-plugin_cpuinfo.c \
-plugin_diskstats.c \
-plugin_dvb.c \
-plugin_exec.c \
-plugin_i2c_sensors.c \
-plugin_imon.c \
-plugin_isdn.c \
-plugin_loadavg.c \
-plugin_meminfo.c \
-plugin_mysql.c \
-plugin_netdev.c \
-plugin_pop3.c \
-plugin_ppp.c \
-plugin_proc_stat.c \
-plugin_python.c \
-plugin_sample.c \
-plugin_seti.c \
-plugin_statfs.c \
-plugin_uname.c \
-plugin_uptime.c \
-plugin_wireless.c \
+EXTRA_lcd4linux_SOURCES= \
+drv_generic_text.c \
+drv_generic_text.h \
+drv_generic_graphic.c \
+drv_generic_graphic.h \
+drv_generic_gpio.c \
+drv_generic_gpio.h \
+drv_generic_serial.c \
+drv_generic_serial.h \
+drv_generic_parport.c \
+drv_generic_parport.h \
+drv_generic_i2c.c \
+drv_generic_i2c.h \
+drv_BeckmannEgle.c \
+drv_BWCT.c \
+drv_Crystalfontz.c \
+drv_Curses.c \
+drv_Cwlinux.c \
+drv_G15.c \
+drv_HD44780.c \
+drv_Image.c \
+drv_LCDLinux.c \
+drv_LCDTerm.c \
+drv_LPH7508.c \
+drv_LUIse.c \
+drv_M50530.c \
+drv_MatrixOrbital.c \
+drv_MilfordInstruments.c \
+drv_Noritake.c \
+drv_NULL.c \
+drv_RouterBoard.c \
+drv_Sample.c \
+drv_serdisplib.c \
+drv_SimpleLCD.c \
+drv_T6963.c \
+drv_Trefon.c \
+drv_USBLCD.c \
+drv_WincorNixdorf.c \
+drv_X11.c \
+ \
+font_6x8.h \
+ \
+lcd4linux_i2c.h \
+ \
+plugin_apm.c \
+plugin_cpuinfo.c \
+plugin_diskstats.c \
+plugin_dvb.c \
+plugin_exec.c \
+plugin_i2c_sensors.c \
+plugin_imon.c \
+plugin_isdn.c \
+plugin_loadavg.c \
+plugin_meminfo.c \
+plugin_mysql.c \
+plugin_netdev.c \
+plugin_pop3.c \
+plugin_ppp.c \
+plugin_proc_stat.c \
+plugin_python.c \
+plugin_sample.c \
+plugin_seti.c \
+plugin_statfs.c \
+plugin_uname.c \
+plugin_uptime.c \
+plugin_wireless.c \
plugin_xmms.c
-EXTRA_DIST = \
-lcd4linux.conf.sample \
-lcd4kde.conf \
-lcd4linux.kdelnk \
-lcd4linux.xpm \
-lcd4linux.lsm \
-curses.m4 \
-AUTHORS \
-CREDITS \
-FAQ \
-NEWS \
-TODO \
-README \
-README.Drivers \
-README.Plugins \
-README.KDE \
+EXTRA_DIST = \
+lcd4linux.conf.sample \
+lcd4kde.conf \
+lcd4linux.kdelnk \
+lcd4linux.xpm \
+lcd4linux.lsm \
+curses.m4 \
+AUTHORS \
+CREDITS \
+FAQ \
+NEWS \
+TODO \
+README \
+README.Drivers \
+README.Plugins \
+README.KDE \
plugin_sample.c