aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorreinelt <>2000-04-05 05:58:36 +0000
committerreinelt <>2000-04-05 05:58:36 +0000
commitccb26ef39584226382cf4b5f895f4e2472975694 (patch)
tree59621ec2a3c57266e71ce8a34428e43186de0266
parent48e22a889b9e36c7a1e9a372cee0b0360c335627 (diff)
downloadlcd4linux-ccb26ef39584226382cf4b5f895f4e2472975694.tar.gz
[lcd4linux @ 2000-04-05 05:58:36 by reinelt]
fixed bug in XWindow.c: union semun isn't defined with glibc-2.1
Diffstat (limited to '')
-rw-r--r--Makefile.in4
-rw-r--r--XWindow.c16
-rwxr-xr-xconfigure59
-rw-r--r--configure.in3
4 files changed, 65 insertions, 17 deletions
diff --git a/Makefile.in b/Makefile.in
index 995d739..ccdca34 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -97,8 +97,8 @@ CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
-DIST_COMMON = README COPYING INSTALL Makefile.am Makefile.in aclocal.m4 \
-configure configure.in install-sh missing mkinstalldirs
+DIST_COMMON = README COPYING INSTALL Makefile.am Makefile.in TODO \
+aclocal.m4 configure configure.in install-sh missing mkinstalldirs
DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
diff --git a/XWindow.c b/XWindow.c
index dd7e518..3be439f 100644
--- a/XWindow.c
+++ b/XWindow.c
@@ -1,4 +1,4 @@
-/* $Id: XWindow.c,v 1.16 2000/04/03 23:53:23 herp Exp $
+/* $Id: XWindow.c,v 1.17 2000/04/05 05:58:36 reinelt Exp $
*
* X11 Driver for LCD4Linux
*
@@ -20,6 +20,10 @@
*
*
* $Log: XWindow.c,v $
+ * Revision 1.17 2000/04/05 05:58:36 reinelt
+ *
+ * fixed bug in XWindow.c: union semun isn't defined with glibc-2.1
+ *
* Revision 1.16 2000/04/03 23:53:23 herp
* fixed a bug that caused pixel-errors ("fliegendreck") under high load
*
@@ -102,6 +106,16 @@
#include "display.h"
#include "pixmap.h"
+/* glibc 2.1 requires defining semun ourselves */
+#ifdef _SEM_SEMUN_UNDEFINED
+union semun {
+ int val;
+ struct semid_ds *buf;
+ unsigned short int *array;
+ struct seminfo *__buf;
+};
+#endif
+
#define BARS ( BAR_L | BAR_R | BAR_U | BAR_D | BAR_H2 | BAR_V2 )
static LCD Lcd;
diff --git a/configure b/configure
index 800327d..2058fc0 100755
--- a/configure
+++ b/configure
@@ -693,7 +693,7 @@ fi
PACKAGE=lcd4linux
-VERSION=0.96
+VERSION=0.96a
if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
{ echo "configure: error: source directory already configured; run "make distclean" there first" 1>&2; exit 1; }
@@ -2235,13 +2235,46 @@ fi
done
+echo $ac_n "checking for pid_t""... $ac_c" 1>&6
+echo "configure:2240: checking for pid_t" >&5
+if eval "test \"`echo '$''{'ac_cv_type_pid_t'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ cat > conftest.$ac_ext <<EOF
+#line 2245 "configure"
+#include "confdefs.h"
+#include <sys/types.h>
+#if STDC_HEADERS
+#include <stdlib.h>
+#include <stddef.h>
+#endif
+EOF
+if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+ egrep "(^|[^a-zA-Z_0-9])pid_t[^a-zA-Z_0-9]" >/dev/null 2>&1; then
+ rm -rf conftest*
+ ac_cv_type_pid_t=yes
+else
+ rm -rf conftest*
+ ac_cv_type_pid_t=no
+fi
+rm -f conftest*
+
+fi
+echo "$ac_t""$ac_cv_type_pid_t" 1>&6
+if test $ac_cv_type_pid_t = no; then
+ cat >> confdefs.h <<\EOF
+#define pid_t int
+EOF
+
+fi
+
echo $ac_n "checking whether time.h and sys/time.h may both be included""... $ac_c" 1>&6
-echo "configure:2240: checking whether time.h and sys/time.h may both be included" >&5
+echo "configure:2273: checking whether time.h and sys/time.h may both be included" >&5
if eval "test \"`echo '$''{'ac_cv_header_time'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2245 "configure"
+#line 2278 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <sys/time.h>
@@ -2250,7 +2283,7 @@ int main() {
struct tm *tp;
; return 0; }
EOF
-if { (eval echo configure:2254: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:2287: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_header_time=yes
else
@@ -2273,13 +2306,13 @@ fi
if test $ac_cv_prog_gcc = yes; then
echo $ac_n "checking whether ${CC-cc} needs -traditional""... $ac_c" 1>&6
-echo "configure:2277: checking whether ${CC-cc} needs -traditional" >&5
+echo "configure:2310: checking whether ${CC-cc} needs -traditional" >&5
if eval "test \"`echo '$''{'ac_cv_prog_gcc_traditional'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_pattern="Autoconf.*'x'"
cat > conftest.$ac_ext <<EOF
-#line 2283 "configure"
+#line 2316 "configure"
#include "confdefs.h"
#include <sgtty.h>
Autoconf TIOCGETP
@@ -2297,7 +2330,7 @@ rm -f conftest*
if test $ac_cv_prog_gcc_traditional = no; then
cat > conftest.$ac_ext <<EOF
-#line 2301 "configure"
+#line 2334 "configure"
#include "confdefs.h"
#include <termio.h>
Autoconf TCGETA
@@ -2319,12 +2352,12 @@ echo "$ac_t""$ac_cv_prog_gcc_traditional" 1>&6
fi
echo $ac_n "checking return type of signal handlers""... $ac_c" 1>&6
-echo "configure:2323: checking return type of signal handlers" >&5
+echo "configure:2356: checking return type of signal handlers" >&5
if eval "test \"`echo '$''{'ac_cv_type_signal'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2328 "configure"
+#line 2361 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <signal.h>
@@ -2341,7 +2374,7 @@ int main() {
int i;
; return 0; }
EOF
-if { (eval echo configure:2345: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:2378: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_type_signal=void
else
@@ -2362,12 +2395,12 @@ EOF
for ac_func in gettimeofday strdup strerror strstr strtol uname
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:2366: checking for $ac_func" >&5
+echo "configure:2399: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2371 "configure"
+#line 2404 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -2390,7 +2423,7 @@ $ac_func();
; return 0; }
EOF
-if { (eval echo configure:2394: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2427: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
diff --git a/configure.in b/configure.in
index 0283d38..f5ae8e2 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(lcd4linux.c)
-AM_INIT_AUTOMAKE(lcd4linux, 0.96)
+AM_INIT_AUTOMAKE(lcd4linux, 0.96a)
dnl Checks for programs.
AC_PROG_AWK
@@ -20,6 +20,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h)
dnl Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_PID_T
AC_HEADER_TIME
dnl Checks for library functions.