aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorreinelt <>2003-10-06 04:30:44 +0000
committerreinelt <>2003-10-06 04:30:44 +0000
commit154afd5f6310abb0fce4cd13bdc24095be94c1d1 (patch)
treef2959885df1c7c380eed49473cb56e1587e5d8e5
parenta185982bf8d2bae041c91088b0e74da1559c9134 (diff)
downloadlcd4linux-154afd5f6310abb0fce4cd13bdc24095be94c1d1.tar.gz
[lcd4linux @ 2003-10-06 04:30:43 by reinelt]
libtool stuff again...
Diffstat (limited to '')
-rw-r--r--Makefile.am13
-rw-r--r--Makefile.in12
-rwxr-xr-xconfigure34
-rw-r--r--configure.in34
4 files changed, 40 insertions, 53 deletions
diff --git a/Makefile.am b/Makefile.am
index 23738b7..eebbefa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,9 +11,6 @@ AM_CFLAGS = $(X_CFLAGS) -D_GNU_SOURCE -Wall
lcd4linux_LDFLAGS = $(X_LIBS)
lcd4linux_LDADD = liblcd4linux.la @DRVLIBS@
-# Fixme: if this line is active, all drivers will be compiled in
-# and not taken from the library
-# lcd4linux_DEPENDENCIES = @DRIVERS@
lcd4linux_SOURCES = \
lcd4linux.c \
@@ -34,9 +31,9 @@ exec.c exec.h \
mail2.c \
socket.c socket.h
+liblcd4linux_la_DEPENDENCIES = @DRIVERS@
liblcd4linux_la_LDFLAGS = -version-info 9:11:9
-# Fixme: why? Why not?
-# liblcd4linux_la_LIBADD=$(DRIVERS)
+liblcd4linux_la_LIBADD = @DRIVERS@
liblcd4linux_la_SOURCES = \
display.c display.h \
@@ -47,11 +44,7 @@ pixmap.c pixmap.h \
bar.c bar.h \
icon.c icon.h \
fontmap.c fontmap.h \
-udelay.c udelay.h \
-@DRIVERS@
-# Fixme: wwhy? why not?
-# Fixme: $DRIVERS? S(DRIVERS)? @DRIVERS@?
-
+udelay.c udelay.h
EXTRA_lcd4linux_SOURCES= \
parport.c parport.h \
diff --git a/Makefile.in b/Makefile.in
index 3f40d87..e11c097 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -100,21 +100,16 @@ AM_CFLAGS = $(X_CFLAGS) -D_GNU_SOURCE -Wall
lcd4linux_LDFLAGS = $(X_LIBS)
lcd4linux_LDADD = liblcd4linux.la @DRVLIBS@
-# Fixme: if this line is active, all drivers will be compiled in
-# and not taken from the library
-# lcd4linux_DEPENDENCIES = @DRIVERS@
lcd4linux_SOURCES = lcd4linux.c pid.c pid.h parser.c parser.h processor.c processor.h evaluator.c evaluator.h expression.c expression.h system.c system.h isdn.c isdn.h mail.c mail.h seti.c seti.h battery.c battery.h dvb.c dvb.h filter.c filter.h widget.c widget.h exec.c exec.h mail2.c socket.c socket.h
+liblcd4linux_la_DEPENDENCIES = @DRIVERS@
liblcd4linux_la_LDFLAGS = -version-info 9:11:9
-# Fixme: why? Why not?
-# liblcd4linux_la_LIBADD=$(DRIVERS)
+liblcd4linux_la_LIBADD = @DRIVERS@
-liblcd4linux_la_SOURCES = display.c display.h debug.c debug.h cfg.c cfg.h lock.c lock.h pixmap.c pixmap.h bar.c bar.h icon.c icon.h fontmap.c fontmap.h udelay.c udelay.h @DRIVERS@
+liblcd4linux_la_SOURCES = display.c display.h debug.c debug.h cfg.c cfg.h lock.c lock.h pixmap.c pixmap.h bar.c bar.h icon.c icon.h fontmap.c fontmap.h udelay.c udelay.h
-# Fixme: wwhy? why not?
-# Fixme: $DRIVERS? S(DRIVERS)? @DRIVERS@?
EXTRA_lcd4linux_SOURCES = parport.c parport.h BeckmannEgle.c Crystalfontz.c Cwlinux.c HD44780.c M50530.c T6963.c USBLCD.c MatrixOrbital.c MilfordInstruments.c PalmPilot.c Raster.c SIN.c Skeleton.c XWindow.c Text.c
@@ -136,7 +131,6 @@ X_CFLAGS = @X_CFLAGS@
X_LIBS = @X_LIBS@
X_EXTRA_LIBS = @X_EXTRA_LIBS@
X_PRE_LIBS = @X_PRE_LIBS@
-liblcd4linux_la_LIBADD =
liblcd4linux_la_OBJECTS = display.lo debug.lo cfg.lo lock.lo pixmap.lo \
bar.lo icon.lo fontmap.lo udelay.lo
bin_PROGRAMS = lcd4linux$(EXEEXT)
diff --git a/configure b/configure
index 487ff80..c123e2f 100755
--- a/configure
+++ b/configure
@@ -20151,7 +20151,7 @@ RASTER="no"
PARPORT="no"
if test "$BECKMANNEGLE" = "yes"; then
- DRIVERS="$DRIVERS BeckmannEgle.$OBJEXT"
+ DRIVERS="$DRIVERS BeckmannEgle.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_BECKMANNEGLE 1
@@ -20160,7 +20160,7 @@ _ACEOF
fi
if test "$CRYSTALFONTZ" = "yes"; then
- DRIVERS="$DRIVERS Crystalfontz.$OBJEXT"
+ DRIVERS="$DRIVERS Crystalfontz.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_CRYSTALFONTZ 1
@@ -20169,7 +20169,7 @@ _ACEOF
fi
if test "$CWLINUX" = "yes"; then
- DRIVERS="$DRIVERS Cwlinux.$OBJEXT"
+ DRIVERS="$DRIVERS Cwlinux.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_CWLINUX 1
@@ -20179,7 +20179,7 @@ fi
if test "$HD44780" = "yes"; then
PARPORT="yes"
- DRIVERS="$DRIVERS HD44780.$OBJEXT"
+ DRIVERS="$DRIVERS HD44780.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_HD44780 1
@@ -20189,7 +20189,7 @@ fi
if test "$M50530" = "yes"; then
PARPORT="yes"
- DRIVERS="$DRIVERS M50530.$OBJEXT"
+ DRIVERS="$DRIVERS M50530.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_M50530 1
@@ -20199,7 +20199,7 @@ fi
if test "$T6963" = "yes"; then
PARPORT="yes"
- DRIVERS="$DRIVERS T6963.$OBJEXT"
+ DRIVERS="$DRIVERS T6963.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_T6963 1
@@ -20208,7 +20208,7 @@ _ACEOF
fi
if test "$USBLCD" = "yes"; then
- DRIVERS="$DRIVERS USBLCD.$OBJEXT"
+ DRIVERS="$DRIVERS USBLCD.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_USBLCD 1
@@ -20217,7 +20217,7 @@ _ACEOF
fi
if test "$MATRIXORBITAL" = "yes"; then
- DRIVERS="$DRIVERS MatrixOrbital.$OBJEXT"
+ DRIVERS="$DRIVERS MatrixOrbital.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_MATRIXORBITAL 1
@@ -20226,7 +20226,7 @@ _ACEOF
fi
if test "$MILINST" = "yes"; then
- DRIVERS="$DRIVERS MilfordInstruments.$OBJEXT"
+ DRIVERS="$DRIVERS MilfordInstruments.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_MILINST 1
@@ -20235,7 +20235,7 @@ _ACEOF
fi
if test "$PALMPILOT" = "yes"; then
- DRIVERS="$DRIVERS PalmPilot.$OBJEXT"
+ DRIVERS="$DRIVERS PalmPilot.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_PALMPILOT 1
@@ -20273,7 +20273,7 @@ echo "$as_me: WARNING: gd.h not found: PNG driver disabled" >&2;}
fi
if test "$SIN" = "yes"; then
- DRIVERS="$DRIVERS SIN.$OBJEXT"
+ DRIVERS="$DRIVERS SIN.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_SIN 1
@@ -20282,7 +20282,7 @@ _ACEOF
fi
if test "$SKELETON" = "yes"; then
- DRIVERS="$DRIVERS Skeleton.$OBJEXT"
+ DRIVERS="$DRIVERS Skeleton.lo"
cat >>confdefs.h <<\_ACEOF
#define WITH_SKELETON 1
@@ -20292,7 +20292,7 @@ fi
if test "$TEXT" = "yes"; then
if test "$has_curses" = true; then
- DRIVERS="$DRIVERS Text.$OBJEXT"
+ DRIVERS="$DRIVERS Text.lo"
DRVLIBS="$DRVLIBS $CURSES_LIBS"
CPPFLAGS="$CPPFLAGS $CURSES_INCLUDES"
@@ -20312,7 +20312,7 @@ if test "$X11" = "yes"; then
echo "$as_me: error: X11 headers or libraries not available: X11 driver disabled" >&2;}
{ (exit 1); exit 1; }; }
else
- DRIVERS="$DRIVERS XWindow.$OBJEXT"
+ DRIVERS="$DRIVERS XWindow.lo"
DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
cat >>confdefs.h <<\_ACEOF
@@ -20328,14 +20328,14 @@ echo "$as_me: error: You should include at least one driver..." >&2;}
{ (exit 1); exit 1; }; }
fi
-# Raster.$OBJEXT depends on PPM or PNG
+# Raster.lo depends on PPM or PNG
if test "$RASTER" = "yes"; then
- DRIVERS="$DRIVERS Raster.$OBJEXT"
+ DRIVERS="$DRIVERS Raster.lo"
fi
# parport driver
if test "$PARPORT" = "yes"; then
- DRIVERS="$DRIVERS parport.$OBJEXT"
+ DRIVERS="$DRIVERS parport.lo"
fi
diff --git a/configure.in b/configure.in
index 6cfe8d1..4edf160 100644
--- a/configure.in
+++ b/configure.in
@@ -139,55 +139,55 @@ RASTER="no"
PARPORT="no"
if test "$BECKMANNEGLE" = "yes"; then
- DRIVERS="$DRIVERS BeckmannEgle.$OBJEXT"
+ DRIVERS="$DRIVERS BeckmannEgle.lo"
AC_DEFINE(WITH_BECKMANNEGLE,1,[junk])
fi
if test "$CRYSTALFONTZ" = "yes"; then
- DRIVERS="$DRIVERS Crystalfontz.$OBJEXT"
+ DRIVERS="$DRIVERS Crystalfontz.lo"
AC_DEFINE(WITH_CRYSTALFONTZ,1,[junk])
fi
if test "$CWLINUX" = "yes"; then
- DRIVERS="$DRIVERS Cwlinux.$OBJEXT"
+ DRIVERS="$DRIVERS Cwlinux.lo"
AC_DEFINE(WITH_CWLINUX,1,[junk])
fi
if test "$HD44780" = "yes"; then
PARPORT="yes"
- DRIVERS="$DRIVERS HD44780.$OBJEXT"
+ DRIVERS="$DRIVERS HD44780.lo"
AC_DEFINE(WITH_HD44780,1,[junk])
fi
if test "$M50530" = "yes"; then
PARPORT="yes"
- DRIVERS="$DRIVERS M50530.$OBJEXT"
+ DRIVERS="$DRIVERS M50530.lo"
AC_DEFINE(WITH_M50530,1,[junk])
fi
if test "$T6963" = "yes"; then
PARPORT="yes"
- DRIVERS="$DRIVERS T6963.$OBJEXT"
+ DRIVERS="$DRIVERS T6963.lo"
AC_DEFINE(WITH_T6963,1,[junk])
fi
if test "$USBLCD" = "yes"; then
- DRIVERS="$DRIVERS USBLCD.$OBJEXT"
+ DRIVERS="$DRIVERS USBLCD.lo"
AC_DEFINE(WITH_USBLCD,1,[junk])
fi
if test "$MATRIXORBITAL" = "yes"; then
- DRIVERS="$DRIVERS MatrixOrbital.$OBJEXT"
+ DRIVERS="$DRIVERS MatrixOrbital.lo"
AC_DEFINE(WITH_MATRIXORBITAL,1,[junk])
fi
if test "$MILINST" = "yes"; then
- DRIVERS="$DRIVERS MilfordInstruments.$OBJEXT"
+ DRIVERS="$DRIVERS MilfordInstruments.lo"
AC_DEFINE(WITH_MILINST,1,[junk])
fi
if test "$PALMPILOT" = "yes"; then
- DRIVERS="$DRIVERS PalmPilot.$OBJEXT"
+ DRIVERS="$DRIVERS PalmPilot.lo"
AC_DEFINE(WITH_PALMPILOT,1,[junk])
fi
@@ -211,18 +211,18 @@ if test "$PPM" = "yes"; then
fi
if test "$SIN" = "yes"; then
- DRIVERS="$DRIVERS SIN.$OBJEXT"
+ DRIVERS="$DRIVERS SIN.lo"
AC_DEFINE(WITH_SIN,1,[junk])
fi
if test "$SKELETON" = "yes"; then
- DRIVERS="$DRIVERS Skeleton.$OBJEXT"
+ DRIVERS="$DRIVERS Skeleton.lo"
AC_DEFINE(WITH_SKELETON,1,[junk])
fi
if test "$TEXT" = "yes"; then
if test "$has_curses" = true; then
- DRIVERS="$DRIVERS Text.$OBJEXT"
+ DRIVERS="$DRIVERS Text.lo"
DRVLIBS="$DRVLIBS $CURSES_LIBS"
CPPFLAGS="$CPPFLAGS $CURSES_INCLUDES"
AC_DEFINE(WITH_TEXT,1,[junk])
@@ -235,7 +235,7 @@ if test "$X11" = "yes"; then
if test "$no_x" = "yes"; then
AC_MSG_ERROR(X11 headers or libraries not available: X11 driver disabled)
else
- DRIVERS="$DRIVERS XWindow.$OBJEXT"
+ DRIVERS="$DRIVERS XWindow.lo"
DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
AC_DEFINE(WITH_X11,1,[junk])
fi
@@ -245,14 +245,14 @@ if test "$DRIVERS" = ""; then
AC_MSG_ERROR([You should include at least one driver...])
fi
-# Raster.$OBJEXT depends on PPM or PNG
+# Raster.lo depends on PPM or PNG
if test "$RASTER" = "yes"; then
- DRIVERS="$DRIVERS Raster.$OBJEXT"
+ DRIVERS="$DRIVERS Raster.lo"
fi
# parport driver
if test "$PARPORT" = "yes"; then
- DRIVERS="$DRIVERS parport.$OBJEXT"
+ DRIVERS="$DRIVERS parport.lo"
fi
AC_SUBST(DRIVERS)