aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorreinelt <>2000-07-31 06:46:35 +0000
committerreinelt <>2000-07-31 06:46:35 +0000
commit06b37e4a51870eca00dc50dfb12d8b2dae027071 (patch)
treebcd8c3489b250b7a4d5e70b1eff01d6080da5174
parente5e83f5c812c2976354bb2293f86ca72aab92bc9 (diff)
downloadlcd4linux-06b37e4a51870eca00dc50dfb12d8b2dae027071.tar.gz
[lcd4linux @ 2000-07-31 06:46:35 by reinelt]
eliminated some compiler warnings with glibc
Diffstat (limited to '')
-rw-r--r--HD44780.c9
-rw-r--r--Makefile.am2
-rw-r--r--Makefile.in2
-rw-r--r--cfg.c7
4 files changed, 15 insertions, 5 deletions
diff --git a/HD44780.c b/HD44780.c
index 4d7e4d7..8ed2f19 100644
--- a/HD44780.c
+++ b/HD44780.c
@@ -1,4 +1,4 @@
-/* $Id: HD44780.c,v 1.4 2000/04/15 16:56:52 reinelt Exp $
+/* $Id: HD44780.c,v 1.5 2000/07/31 06:46:35 reinelt Exp $
*
* driver for display modules based on the HD44780 chip
*
@@ -20,6 +20,10 @@
*
*
* $Log: HD44780.c,v $
+ * Revision 1.5 2000/07/31 06:46:35 reinelt
+ *
+ * eliminated some compiler warnings with glibc
+ *
* Revision 1.4 2000/04/15 16:56:52 reinelt
*
* moved delay loops to udelay.c
@@ -59,11 +63,12 @@
#include <stdlib.h>
#include <stdio.h>
+#include <string.h>
#include <unistd.h>
#include <time.h>
#include <signal.h>
#include <errno.h>
-#include <asm/io.h>
+#include <sys/io.h>
#include "debug.h"
#include "cfg.h"
diff --git a/Makefile.am b/Makefile.am
index 46191f7..9dfdb69 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@ CLEANFILES = *~
bin_PROGRAMS = lcd4linux
-AM_CFLAGS = $(X_CFLAGS) -Wall
+AM_CFLAGS = $(X_CFLAGS) -D_GNU_SOURCE -Wall
lcd4linux_LDFLAGS = $(X_LIBS)
if WITH_X
lcd4linux_LDADD = -lX11
diff --git a/Makefile.in b/Makefile.in
index 25a80e7..adb347b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -69,7 +69,7 @@ CLEANFILES = *~
bin_PROGRAMS = lcd4linux
-AM_CFLAGS = $(X_CFLAGS) -Wall
+AM_CFLAGS = $(X_CFLAGS) -D_GNU_SOURCE -Wall
lcd4linux_LDFLAGS = $(X_LIBS)
@WITH_X_TRUE@lcd4linux_LDADD = -lX11
diff --git a/cfg.c b/cfg.c
index b4f261f..af0afd4 100644
--- a/cfg.c
+++ b/cfg.c
@@ -1,4 +1,4 @@
-/* $Id: cfg.c,v 1.7 2000/04/15 11:13:54 reinelt Exp $
+/* $Id: cfg.c,v 1.8 2000/07/31 06:46:35 reinelt Exp $
*
* config file stuff
*
@@ -20,6 +20,10 @@
*
*
* $Log: cfg.c,v $
+ * Revision 1.8 2000/07/31 06:46:35 reinelt
+ *
+ * eliminated some compiler warnings with glibc
+ *
* Revision 1.7 2000/04/15 11:13:54 reinelt
*
* added '-d' (debugging) switch
@@ -92,6 +96,7 @@
*
*/
+
#include <stdlib.h>
#include <stdio.h>
#include <string.h>