aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/makefile_set_debian_buildflags.patch29
-rw-r--r--debian/patches/makefile_set_debian_paths.patch22
-rw-r--r--debian/patches/series2
3 files changed, 53 insertions, 0 deletions
diff --git a/debian/patches/makefile_set_debian_buildflags.patch b/debian/patches/makefile_set_debian_buildflags.patch
new file mode 100644
index 0000000..2ea6e17
--- /dev/null
+++ b/debian/patches/makefile_set_debian_buildflags.patch
@@ -0,0 +1,29 @@
+Description: Set the appropriate Debian buildflags flags in Makefile
+Author: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Mon, 28 May 2012 00:37:27 +0100
+---
+--- figlet-2.2.4.orig/Makefile
++++ figlet-2.2.4/Makefile
+@@ -19,10 +19,11 @@
+ SHELL = /bin/sh
+
+ # The C compiler and linker to use
++CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+ CC = gcc
+-CFLAGS = -g -O2 -Wall
++CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+ LD = gcc
+-LDFLAGS =
++LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+
+ # Feature flags:
+ # define TLF_FONTS to use TOIlet TLF fonts
+@@ -62,7 +63,7 @@ DFILES = Makefile Makefile.tc $(MANUAL)
+ crc.h inflate.h zipio.h utf8.h run-tests.sh figmagic
+
+ .c.o:
+- $(CC) -c $(CFLAGS) $(XCFLAGS) -DDEFAULTFONTDIR=\"$(DEFAULTFONTDIR)\" \
++ $(CC) -c $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) -DDEFAULTFONTDIR=\"$(DEFAULTFONTDIR)\" \
+ -DDEFAULTFONTFILE=\"$(DEFAULTFONTFILE)\" -o $*.o $<
+
+ all: $(BINS)
diff --git a/debian/patches/makefile_set_debian_paths.patch b/debian/patches/makefile_set_debian_paths.patch
new file mode 100644
index 0000000..992733e
--- /dev/null
+++ b/debian/patches/makefile_set_debian_paths.patch
@@ -0,0 +1,22 @@
+Description: Set the appropriate Debian paths in Makefile
+Author: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Mon, 28 May 2012 00:37:27 +0100
+---
+--- figlet-2.2.4.orig/Makefile
++++ figlet-2.2.4/Makefile
+@@ -30,13 +30,13 @@ LDFLAGS = $(shell dpkg-buildflags --get
+ XCFLAGS = -DTLF_FONTS
+
+ # Where to install files
+-prefix = /usr/local
++prefix = /usr
+
+ # Where the executables should be put
+ BINDIR = $(prefix)/bin
+
+ # Where the man page should be put
+-MANDIR = $(prefix)/man
++MANDIR = $(prefix)/share/man
+
+ # Where figlet will search first for fonts (the ".flf" files).
+ DEFAULTFONTDIR = $(prefix)/share/figlet
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5867dd5
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+makefile_set_debian_buildflags.patch
+makefile_set_debian_paths.patch