aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-x[-rw-r--r--]debian/examples/moolets9
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 1a7c191..cdaad76 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ figlet (2.2.5-1) UNRELEASED; urgency=low
- Various lintian fixes
- Update package description (closes: #557254)
- Update debian/copyright (closes: #436302)
+ - Fix moolets bashism (closes: #530082)
- Add watchfile
- Add Homepage to debian/control
- Remove references to deprecated figfonts(-cjk) packages
diff --git a/debian/examples/moolets b/debian/examples/moolets
index 284ebd3..3e0b74e 100644..100755
--- a/debian/examples/moolets
+++ b/debian/examples/moolets
@@ -2,13 +2,12 @@
# Prints "Moo" using every font installed on /usr/share/figlet
# Written by Sandro Tosi <matrixhasu@gmail.com>
-
-> /tmp/moolets
+# Modified by Jonathan McCrohan <jmccrohan@gmail.com>
for file in /usr/share/figlet/*.flf ; do
FONT=`basename $file | sed 's|\(.*\)\.\(.*\)|\1|'`
- echo -e "Font: $FONT \n" >> /tmp/moolets
- figlet -f $FONT Moo >> /tmp/moolets
- echo -e "\n\n" >> /tmp/moolets
+ printf "Font: $FONT\n"
+ figlet -f $FONT Moo
+ printf "\n"
done
or: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
# UK, Bressay
# Auto-generated from http://www.dtg.org.uk/retailer/dtt_channels.html
# and http://www.ofcom.org.uk/static/reception_advice/index.asp.html
# T freq bw fec_hi fec_lo mod transmission-mode guard-interval hierarchy
T 474000000 8MHz 3/4 NONE QAM16 2k 1/32 NONE
T 497833000 8MHz 2/3 NONE QAM64 2k 1/32 NONE
T 521833000 8MHz 2/3 NONE QAM64 2k 1/32 NONE
T 553833000 8MHz 3/4 NONE QAM16 2k 1/32 NONE
T 834000000 8MHz 3/4 NONE QAM16 2k 1/32 NONE
T 850000000 8MHz 3/4 NONE QAM16 2k 1/32 NONE