diff options
author | Jonathan McCrohan <jmccrohan@gmail.com> | 2012-05-08 14:52:11 +0100 |
---|---|---|
committer | Jonathan McCrohan <jmccrohan@gmail.com> | 2012-05-08 14:52:11 +0100 |
commit | 017f336a5121897cd64179e84ded15e1dd37bd92 (patch) | |
tree | 2ae42241ba854d6c7726ad857195d0f5edafa053 /Makefile | |
parent | dee0cd250574b52e74a9390f6f9c1efd818223d4 (diff) | |
parent | 8fdab96d486ba52601544c67c38625480ddf7640 (diff) | |
download | figlet-017f336a5121897cd64179e84ded15e1dd37bd92.tar.gz |
Merge tag 'upstream/2.2.4'
Upstream version 2.2.4
Diffstat (limited to '')
-rw-r--r-- | Makefile | 62 |
1 files changed, 44 insertions, 18 deletions
@@ -1,5 +1,5 @@ -# Makefile for figlet version 2.2.3 (11 Jan 2011) -# adapted from Makefile for figlet version 2.2.2 (05 July 2005) +# Makefile for figlet version 2.2.4 (26 Jan 2011) +# adapted from Makefile for figlet version 2.2.2 (05 July 2005) # adapted from Makefile for figlet version 2.2 (15 Oct 1996) # Copyright 1993, 1994,1995 Glenn Chappell and Ian Chai # Copyright 1996, 1997, 1998, 1999, 2000, 2001 John Cowan @@ -24,38 +24,45 @@ CFLAGS = -g -O2 -Wall LD = gcc LDFLAGS = +# Feature flags: +# define TLF_FONTS to use TOIlet TLF fonts +XCFLAGS = -DTLF_FONTS + +# Where to install files +prefix = /usr/local + # Where the executables should be put -BINDIR = /usr/local/bin +BINDIR = $(prefix)/bin # Where the man page should be put -MANDIR = /usr/local/man +MANDIR = $(prefix)/man # Where figlet will search first for fonts (the ".flf" files). -DEFAULTFONTDIR = /usr/local/share/figlet -# Use this definition if you can't put things in /usr/local/share/figlet -DEFAULTFONTDIR = fonts +DEFAULTFONTDIR = $(prefix)/share/figlet +# Use this definition if you can't put things in $(prefix)/share/figlet +#DEFAULTFONTDIR = fonts -# The filename of the font to be used if no other is specified -# (standard.flf is recommended, but any other can be used). -# This font file should reside in the directory specified by -# DEFAULTFONTDIR. -DEFAULTFONTFILE = standard.flf +# The filename of the font to be used if no other is specified, +# without suffix.(standard is recommended, but any other can be +# used). This font file should reside in the directory specified +# by DEFAULTFONTDIR. +DEFAULTFONTFILE = standard ## ## END OF CONFIGURATION SECTION -## +## -VERSION = 2.2.3 +VERSION = 2.2.4 DIST = figlet-$(VERSION) -OBJS = figlet.o zipio.o crc.o inflate.o +OBJS = figlet.o zipio.o crc.o inflate.o utf8.o BINS = figlet chkfont figlist showfigfonts MANUAL = figlet.6 chkfont.6 figlist.6 showfigfonts.6 DFILES = Makefile Makefile.tc $(MANUAL) $(OBJS:.o=.c) chkfont.c \ figlist showfigfonts CHANGES FAQ README LICENSE figfont.txt \ - crc.h inflate.h zipio.h + crc.h inflate.h zipio.h utf8.h run-tests.sh .c.o: - $(CC) -c $(CFLAGS) -DDEFAULTFONTDIR=\"$(DEFAULTFONTDIR)\" \ + $(CC) -c $(CFLAGS) $(XCFLAGS) -DDEFAULTFONTDIR=\"$(DEFAULTFONTDIR)\" \ -DDEFAULTFONTFILE=\"$(DEFAULTFONTFILE)\" -o $*.o $< all: $(BINS) @@ -84,9 +91,28 @@ dist: cp $(DFILES) $(DIST)/ mkdir $(DIST)/fonts cp fonts/*.fl[fc] $(DIST)/fonts + mkdir $(DIST)/tests + cp tests/*txt tests/emboss.tlf $(DIST)/tests tar cvf - $(DIST) | gzip -9c > $(DIST).tar.gz rm -Rf $(DIST) - ls -l $(DIST).tar.gz + tar xf $(DIST).tar.gz + (cd $(DIST); make all check vercheck) + @rm -Rf $(DIST) + @echo + @ls -l $(DIST).tar.gz + +check: + @echo -n "Run tests in " + @pwd + @./run-tests.sh fonts + @echo + +vercheck: + @echo -n "Infocode: "; ./figlet -I1 + @./figlet -v|sed -n '/Version/s/.*\(Version\)/\1/p' + @echo -n "README: "; head -1 < README|sed 's/.*) //' + @echo -n "FAQ: "; grep latest FAQ|sed 's/ and can.*//' + @grep -h "^\.TH" *.6 $(OBJS) chkfont.o getopt.o: Makefile chkfont.o: chkfont.c |